Results 1 to 4 of 4

Thread: broken barcode reader with chg-zd-mtx

  1. #1

    Unhappy broken barcode reader with chg-zd-mtx

    Hi All,

    I have been using amanda with chg-zd-mtx to use my HP 16 Tape autoloader. However the barcode reader on the autoloader is broke and chg-zd-mtx now can't pick and load the right tape from the daily amdump run.
    I am now having to use MTX commands each afternoon to load the right tape for the nightly run.

    Question: How can i hard code the slot to label so that chg-zd-mtx knows what slot tape to load?

    Surely this can be done, right???

    Thanks

    Brandons

  2. #2
    Join Date
    Mar 2007
    Location
    Chicago, IL
    Posts
    688

    Default

    You should just be able to set "havereader" to 0 to indicate that no reader is availble. Then chg-zd-mtx will search through the changer as it would for a barcode-less changer.

  3. #3
    Join Date
    Sep 2007
    Location
    Massachusetts
    Posts
    58

    Default

    Interesting. I have a barcode reader. It works and pulls out the barcode to go in the Amanda database. However, in my configuration, with chg-zd-mtx and havereader=1 or yes, it still scans through looking for a tape to use. Because my tapes are loaded in sequence, it usually just goes to the next one. But, if I leave it out of position, it will scan.

  4. #4

    Default broken barcode reader with chg-zd-mtx

    Thanks for getting back on this.

    Yes i did know of the havereader=no option but still i need to link tape label to the slots. Ie amanda needs to know how to find a specific tape label in a specific slot. This was done via barcodes file called changer-barcodes.

    Can anyone sugguest a way forward?

    Thaxs

    Brandon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •