Results 1 to 5 of 5

Thread: Defined new disk "Permission denied"

  1. #1

    Unhappy Defined new disk "Permission denied"

    Hi All,

    I'm trying to add a new disk in the disklist file for a backup set, seems simple enough and I've had no trouble in the past.
    However I've run into this strange problem. Amcheck log below.

    ================================================== =======

    Amanda Backup Client Hosts Check
    --------------------------------
    ERROR: euser01: [could not access /caer/e/data/prj/gui/worlds (/caer/e/data/prj/gui/worlds): Permission denied]
    Client check: 9 hosts checked in 10.240 seconds, 1 problem found

    ================================================== =======

    This seems pretty straight forward, but I've checked all the directory and file permissions for the "/caer/e/data/prj/gui/worlds" directory, including all the root directories, and I don't see why I can't backup this directory.
    From "/caer/e" onwards all file/directory permissions are set to the user and group named "ecs".

    Amanda is installed under the account "amanda", but I've added the amanda user to the "ecs" group (/etc/group), so in theory Amanda should be able to access these files. If I login with the "amanda" shell account, I can browse and create files in any of those directories so I assume Amanda backup would work.
    Amanda backup using amdump seems to work, however amcheck would fail with the error message above.

    Anyone ever run into this situation?

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Are you sure it is a member of group "ecs" when run from xinetd?
    What's your xinetd config?
    Do you have: groups = yes

  3. #3

    Default

    I'm pretty sure it's part of the group ecs. Output from id command:

    -bash-3.00$ id
    uid=33(amanda) gid=6(disk) groups=6(disk),5001(ecs_e),

    Here's the contents of configurations in xinetd.d

    /etc/xinetd.d/amanda:
    service amanda
    {
    socket_type = dgram
    protocol = udp
    wait = yes
    user = amanda
    group = disk
    groups = yes
    server = /usr/lib/amanda/amandad
    disable = no
    }

    /etc/xinetd.d/amandaidx:
    service amandaidx
    {
    socket_type = stream
    protocol = tcp
    wait = no
    user = amanda
    group = disk
    groups = yes
    server = /usr/lib/amanda/amindexd
    disable = no
    }

    /etc/xinetd.d/amidxtape:
    service amidxtape
    {
    socket_type = stream
    protocol = tcp
    wait = no
    user = amanda
    group = disk
    groups = yes
    server = /usr/lib/amanda/amidxtaped
    disable = no
    }

  4. #4
    Join Date
    Oct 2005
    Location
    Bay Area, CA
    Posts
    124

    Default

    does amdump succeed?

    Something amcheck fails while amdump succeeds due to permission on the files and directories.

    Ref: [url]http://wiki.zmanda.com/index.php/Why_does_amcheck_fail_while_amdump_succeeds%3F[/url]

  5. #5

    Default

    Opps... nevermind, figured out what my problem was.

    I forgot to kill -HUP the xinetd daemon after making changes to the groupings.

    All fix now. Thanks for all the replies.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •