Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: amrecover error

  1. #1
    Join Date
    Jul 2007
    Posts
    26

    Exclamation amrecover error

    Greetings,

    Running amrecover from a client machine results in the following:

    # amrecover
    AMRECOVER Version 2.5.2p1. Contacting server on amanda.domain.com ...
    [request failed: recv error: Connection reset by peer]

    The debug output:

    recover: debug 1 pid 20461 ruid 0 euid 0: start at Mon Jul 16 16:06:23 2007
    Reading conf file "/etc/amanda/amanda-client.conf".
    Reading conf file "/etc/amanda/DailySet1/amanda-client.conf".
    amrecover: debug 1 pid 20461 ruid 0 euid 0: rename at Mon Jul 16 16:06:23 2007
    amrecover: time 0.001: security_getdriver(name=bsdtcp) returns 0x690d00
    amrecover: time 0.001: security_handleinit(handle=0x99c2718, driver=0x690d00 (BSDTCP))
    amrecover: time 0.004: security_streaminit(stream=0x99c2c30, driver=0x690d00 (BSDTCP))
    amrecover: time 0.005: connect_port: Skip port 512: Owned by exec.
    amrecover: time 0.005: connect_port: Skip port 513: Owned by login.
    amrecover: time 0.005: connect_port: Skip port 514: Owned by shell.
    amrecover: time 0.006: connect_port: Skip port 515: Owned by printer.
    amrecover: time 0.006: connect_port: Skip port 516: Owned by videotex.
    amrecover: time 0.012: connect_port: Try port 517: Available -
    amrecover: time 0.014: connected to 192.168.xx.x.10080
    amrecover: time 0.014: our side is 0.0.0.0.517
    amrecover: time 0.014: try_socksize: send buffer size is 65536
    amrecover: time 0.014: try_socksize: receive buffer size is 65536
    amrecover: time 0.021: security_stream_seterr(0x99c2c30, recv error: Connection reset by peer)
    amrecover: time 0.021: security_seterror(handle=0x99c2718, driver=0x690d00 (BSDTCP) error=recv error: Connection reset by peer)
    amrecover: time 0.021: security_close(handle=0x99c2718, driver=0x690d00 (BSDTCP))
    amrecover: time 0.021: security_stream_close(0x99c2c30)

    I'm not sure what's causing the problem as it seems to be connecting to the server and the correct auth is being used. Any help would be greatly appreciated...definitely need to be able to restore files....
    Last edited by t0ta11ed; August 6th, 2007 at 12:04 PM.

  2. #2
    Join Date
    Jul 2007
    Posts
    26

    Default Anyone?

    I'm at my wits end here. I've gone through many of the other threads here regarding amrecover issues, but with no luck. Does anyone know what could be causing the problem in the original post? Amanda is useless if I can't restore anything and it's pissing me off!

  3. #3
    Join Date
    Oct 2005
    Location
    Bay Area, CA
    Posts
    124

    Default

    Can you please list the file /etc/xinetd.d/amanda* on the client?
    Is there a firewall between the server and the client?

  4. #4
    Join Date
    Jul 2007
    Posts
    26

    Default Here ya go..xinetd.d/amandaclient on client machine

    There is no firewall between them.

    service amanda
    {
    disable = no
    socket_type = stream
    protocol = tcp
    wait = no
    user = amandabackup
    group = disk
    groups = yes
    server = /usr/lib/amanda/amandad
    server_args = -auth=bsdtcp amdump amindexd amidxtaped
    }

  5. #5
    Join Date
    Oct 2005
    Location
    Bay Area, CA
    Posts
    124

    Default

    Oh, I mean to ask about the /etc/xinetd.d/amanda* on the server.
    amrecover needs to talk to the tape and index server one the 'server'.

    On the server, do
    netstat -a |grep amanda

    If amanda is listening on the server, the above command should give output similar to the following:

    tcp 0 0 *:amanda *:* LISTEN

  6. #6
    Join Date
    Jul 2007
    Posts
    26

    Default Okayyy

    Amanda is listening on the server.

    The xinetd file is essentially the same as the client, but here ya go:

    service amanda
    {
    disable = no
    socket_type = stream
    protocol = tcp
    wait = no
    user = amandabackup
    group = disk
    groups = yes
    server = /usr/lib/amanda/amandad
    server_args = -auth=bsdtcp amdump amindexd amidxtaped
    }

  7. #7
    Join Date
    Jan 2007
    Location
    Richland, WA [USA]
    Posts
    78

    Default

    Quote Originally Posted by t0ta11ed View Post
    Amanda is listening on the server.

    The xinetd file is essentially the same as the client, but here ya go:
    ...
    }
    I believe that on the server, you will want to have additonal "services" in there for "amandaidx" and "amidxtape", or you won't have those services (and will have a write-only backup server! 8^).

    The document at: [url]http://wiki.zmanda.com/index.php/How_Toiagnose_%22host_down%22_errors[/url]

    shows an example of the other files (using user "amanda", and separate files for each service, so maybe an older example).

    Here's what I use on my Amanda server, all in the /etc/xinetd,d/amanda file:

    Code:
    service amanda
    {
        disable          = no
        socket_type      = stream
        protocol         = tcp
        wait             = no
        user             = amandabackup
        group            = disk
        groups           = yes
        only_from        = .XXXX.domain.com .domain.com localhost
        log_type         = SYSLOG daemon warning
        log_on_success   = HOST PID EXIT DURATION
        log_on_failure   = HOST ATTEMPT
        server           = /usr/lib/amanda/amandad
        server_args      = -auth=bsdtcp amdump amindexd amidxtaped
    }
    
    service amandaidx
    {
        disable          = no
        socket_type      = stream
        protocol         = tcp
        wait             = no
        user             = amandabackup
        group            = disk
        groups           = yes
        only_from        = .XXXX.domain.com .domain.com localhost
        log_type         = SYSLOG daemon warning
        log_on_success   = HOST PID EXIT DURATION
        log_on_failure   = HOST ATTEMPT
        server           = /usr/lib/amanda/amindexd
    }
    
    service amidxtape
    {
        disable          = no
        socket_type      = stream
        protocol         = tcp
        wait             = no
        user             = amandabackup
        group            = disk
        groups           = yes
        only_from        = .XXXX.domain.com .domain.com localhost
        log_type         = SYSLOG daemon warning
        log_on_success   = HOST PID EXIT DURATION
        log_on_failure   = HOST ATTEMPT
        server           = /usr/lib/amanda/amidxtaped
    }
    spock{rakowski}139:
    and that works for me. I restrict access to only systems on my two domains (I have a dual-interface backup server that does backups in two different network zones), I use syslog logging of activity, and I'm running in BSDTCP mode.

    Make sure that xinetd is running, and if you change any configuration options, remember to either send the xinetd process a HUP signal, or run "service xinetd reload" (or "restart") to get the changes into the xinetd listener.

    HTH. Best regards,

    -Andrew

  8. #8
    Join Date
    Jul 2007
    Posts
    26

    Default Hmm

    I did try those other entries but it didn't seem to make a difference so I removed them. I'll add them back and test. I was wondering if amanda was capable of backing up across subnets...so dual NICs would do the trick?

  9. #9
    Join Date
    Jul 2007
    Posts
    26

    Default Hmm

    I added them back, restarted xinetd and ran the amrecover command from the client, same error. Does the client xinetd file need to have the same thing?

  10. #10
    Join Date
    Jan 2007
    Location
    Richland, WA [USA]
    Posts
    78

    Default

    Quote Originally Posted by t0ta11ed View Post
    I did try those other entries but it didn't seem to make a difference so I removed them. I'll add them back and test. I was wondering if amanda was capable of backing up across subnets...so dual NICs would do the trick?
    If you allow traffic between your subnets (ie: you have routers routing traffic, and no firewalls blocking traffic), there should be no need for multiple NICs/interfaces. I use multiple interfaces to avoid sending traffic through extra routers and firewalls in our semi-complex network environment.

    On your client, when you run your "amrecover" command (as root), you either need to have correct defaults in your /etc/amanda/amanda.conf file to point out the configuration, index server and tape server you want to use, or you need to specify them on the command line. Try fully specifying things:

    # amrecover XXXXdaily -s amanda01 -t amanda01

    you need to have the client's /etc/amanda/amanda.conf file specifying the right authentication method as well. My client /etc/amanda/amanda.conf file looks like this (with the comments stripped out):

    [code]
    spock{root}23: egrep -v ^# /etc/amanda/amanda-client.conf

    conf "XXXXdaily" # your config name
    index_server "amanda01.emsl.pnl.gov" # your amindexd server
    tape_server "amanda01.emsl.pnl.gov" # your amidxtaped server
    tapedev "" # your tape device

    auth "bsdtcp"
    ssh_keys "" # your ssh keys file if you use ssh auth

    spock{root}24:

    If that doesn't work, you might want to try running tcpdump and see what is actually happening (make sure you're using TCP and not UDP, etc.) and read through the debug files that should be in the /tmp/amanda/ directory.

    One last thing you can do to make sure is to make sure your Amanda severis actually listening on the TCP ports. You can use "netstat -a" to look at listening ports. For instance:

    Code:
    [root@amanda01 XXXXset1]# netstat -a | grep LISTEN | grep ^tcp
    tcp        0      0 *:amanda                    *:*                         LISTEN
    tcp        0      0 *:amandaidx                 *:*                         LISTEN
    tcp        0      0 *:amidxtape                 *:*                         LISTEN
    tcp        0      0 *:ssh                       *:*                         LISTEN
    tcp        0      0 localhost:smtp              *:*                         LISTEN
    [root@amanda01 XXXXset1]#
    If that fails, hopefully some Zmanda person will jump in here with more ideas (I'm just a user of Amanda after all... 8^)

    Cheers,

    -Andrew

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •