Application :ZRM for MySql
Version: 3.7 & 3.8

Description:

Full Backups failing after enabling GTID (Global transaction identifier) on MySQL. Output of mysqldump is as below:

- Warning: A partial dump from a server that has GTIDs will by default include the GTIDs of all transactions, even those that changed suppressed parts of the database. If you don't want to restore GTIDs, pass --set-gtid-purged=OFF. To make a complete dump, pass --all-databases --triggers --routines --events.]

Solution:

This issue can be fixed by adding the below statement to local configuration file for ZRM.

1. Edit configuration file

#vim /etc/mysqlzrm/Backupset_name/mysql-zrm.conf

2. Add below line to configuration file

extra-mysqldump-options="--set-gtid-purged=OFF"

3. Restart ZRM Service

# service zmc_zrm restart

Please reply to the post if you still face the issue or you can reach support.
You can reach Support @ [email protected] or call us @ 888-496-2632 (U.S.)/ 408-732-3208 (INTL)