Results 1 to 4 of 4

Thread: trying to recover data from backup using amrestore

Hybrid View

  1. #1
    Join Date
    Jun 2013
    Posts
    6

    Default trying to recover data from backup using amrestore

    I was previously running RedHat Enterprise 6 (x86) with amanda 3.3.3 installed. I had backups setup which were being dumped
    onto a SSD disk (500GB). There were 25 vtapes setup for it to use. These were all saved.

    I just finished upgrading to RHEL 7.4 with Amanda 3.5.1 (64 bit) and am trying to get the data saved on the vtapes to be recognized
    by the config so I can recover some data which go pooched during the upgrade.

    I'm getting this when trying to run a dump after doing the config:

    taper: Slot 1 with label DailySet1-01 is not in the tapelist
    taper: Slot 2 with label DailySet1-2 is not in the tapelist
    taper: Slot 3 with label DailySet1-3 is not in the tapelist
    taper: Slot 4 with label DailySet1-4 is not in the tapelist
    taper: Slot 5 with label DailySet1-5 is not in the tapelist
    taper: Slot 6 with label DailySet1-6 is not in the tapelist
    taper: Slot 7 with label DailySet1-7 is not in the tapelist
    taper: Slot 8 with label DailySet1-8 is not in the tapelist
    taper: Slot 9 with label DailySet1-9 is not in the tapelist
    taper: Slot 10 with label DailySet1-10 is not in the tapelist
    taper: Slot 11 with label DailySet1-11 is not in the tapelist
    taper: Slot 12 with label DailySet1-12 is not in the tapelist
    taper: Slot 13 with label DailySet1-13 is not in the tapelist
    taper: Slot 14 with label DailySet1-14 is not in the tapelist
    taper: Slot 15 with label DailySet1-15 is not in the tapelist
    taper: Slot 16 with label DailySet1-16 is not in the tapelist
    taper: Slot 17 with label DailySet1-17 is not in the tapelist
    taper: Slot 18 with label DailySet1-18 is not in the tapelist
    taper: Slot 19 with label DailySet1-19 is not in the tapelist
    taper: Slot 20 with label DailySet1-20 is not in the tapelist
    taper: Slot 21 with label DailySet1-21 is not in the tapelist
    taper: Slot 22 with label DailySet1-22 is not in the tapelist
    taper: Slot 23 with label DailySet1-23 is not in the tapelist
    taper: Slot 24 with label DailySet1-24 is not in the tapelist
    taper: Slot 25 with label DailySet1-25 is not in the tapelist

    Here is my current config setup in my amanda.conf:

    org "DailySet1"
    infofile "/backup/amanda/state/curinfo"
    logdir "/backup/amanda/state/log"
    indexdir "/backup/amanda/state/index"
    dumpuser "amandabackup"

    tpchanger "chg-disk:/backup/amanda/vtapes"
    labelstr "DailySet1-[0-9]"
    autolabel "DailySet1-%" EMPTY VOLUME_ERROR
    tapecycle 25
    dumpcycle 3 days
    amrecover_changer "changer"

    tapetype "TEST-TAPE"
    define tapetype TEST-TAPE {
    length 100 mbytes
    filemark 4 kbytes
    }

    define dumptype simple-gnutar-local {
    auth "local"
    compress CLIENT FAST
    program "GNUTAR"
    }

    holdingdisk hd1 {
    directory "/backup/amanda/holding"
    use 50 gbytes
    chunksize 1 mbyte
    }

    Here is the directory structure on the SSD disk holding the vtapes that were in existence
    PRIOR to the upgrade which I'm trying to get the new install to again use:

    -bash-4.2$ cd /backup/amanda/vtapes/
    -bash-4.2$ ls
    data slot10 slot12 slot14 slot16 slot18 slot2 slot21 slot23 slot25 slot4 slot6 slot8 state
    slot1 slot11 slot13 slot15 slot17 slot19 slot20 slot22 slot24 slot3 slot5 slot7 slot9

    -bash-4.2$ ls -l slot1
    total 3210124
    -rw-------. 1 amandabackup disk 32768 Jul 1 2016 00000.DailySet1-01
    -rw-------. 1 amandabackup disk 3287131920 Jul 1 2016 00001.macarhel.aliant.ca._home_wendell.1

    Any idea why amanda is not able to look at them properly??

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Do you have the tapelist file from before the upgrade? If not, you must manually rebuild it.
    You also needs all log.<DATASTAMP>.*

  3. #3
    Join Date
    Jun 2013
    Posts
    6

    Default

    Quote Originally Posted by martineau View Post
    Do you have the tapelist file from before the upgrade? If not, you must manually rebuild it.
    You also needs all log.<DATASTAMP>.*
    The reason I did the upgrade from 6.4 RHEL -> 7.4 was for 64 bit support. RHEL was crashing during amanda backups during
    file creation due to OOM constraints. When this was occuring, it was aborting my backups. Fortunately, I found 1 backup that
    I had run manually outside of the X GUI being up that worked. So I was able to restore the files in question from the backup
    of my home directory by skipping past the 32K header block in the gzip tarball file amanda creates.

    thx.

  4. #4
    Join Date
    Jul 2018
    Posts
    13

    Default

    Help anyone?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •