Results 1 to 5 of 5

Thread: FreeBSD doesn't have libdl so Amanda 3.4.3 and 3.4.4 won't build

  1. #1
    Join Date
    Apr 2008
    Location
    Goshen, KY
    Posts
    38

    Default FreeBSD doesn't have libdl so Amanda 3.4.3 and 3.4.4 won't build

    FreeBSD doesn't have libdl so Amanda 3.4.3 and 3.4.4 won't build.

    The Makefile.in in the device-src directory unconditionally tries to include -ldl. This causes FreeBSD to fail during the build.

    The problem area in device-src/Makefile.in is about line 1788.

    I have created a local patch to circumvent this problem and both 3.4.3 and 3.4.4 seem okay, otherwise.

    Thanks.

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,046

    Default

    Can you try the attached patch
    Attached Files Attached Files

  3. #3
    Join Date
    Apr 2008
    Location
    Goshen, KY
    Posts
    38

    Default

    Jean-Louis,

    Thanks for the quick reply.

    The patch appears to apply correctly. configure appear to run correctly.

    The attachment shows an error which occurs during gmake.

    I have time and computers to do any testing necessary.

    Thanks.

    David Boyd.
    Attached Files Attached Files

  4. #4
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,046

    Default

    Some tools are missing to build amanda, (not the same version as I have).
    You can try to do:./autogen
    before the ./configure

    You can also try to download amanda-3.4.5.tar.gz, the patch is included in it.

  5. #5
    Join Date
    Apr 2008
    Location
    Goshen, KY
    Posts
    38

    Default

    Jean-Louis,

    I couldn't get ./autogen to work ... same complaint about aclocal.

    I downloaded 3.4.5 and it configured and build just peachy.

    I am testing now, but everything looks good.

    Thank you.

    David Boyd.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •