Results 1 to 2 of 2

Thread: Amanda 3.4.1 and amazon S3

  1. #1
    Join Date
    Nov 2016
    Posts
    1

    Default Amanda 3.4.1 and amazon S3

    Hello,

    I'm trying to backup to amazon S3 but I'm not entirely successful.

    My /etc/amanda/MyS3Conf/amanda.conf

    Code:
    org "MyS3Conf"
    infofile "/amanda/state/curinfo"
    logdir "/amanda/state/log"
    indexdir "/amanda/state/index"
    dumpuser "amandabackup"
    
    # amazonaws S3
    device_property "S3_SSL" "YES"
    device_property "S3_ACCESS_KEY" "AKIAJZMOKO4WY7CKXUCQ"
    device_property "S3_SECRET_KEY" "asdfasdf"
    
    tpchanger "chg-multi:s3:EXTTEST-backups/MyS3Config1/slot-{01,02,03,04,05,06,07,08,09,10}"
    changerfile  "s3-statefile"
    
    tapetype S3
    define tapetype S3 {
        comment "S3 Bucket"
        length 10240 gigabytes # Bucket size 10TB
    }
    
    define dumptype simple-gnutar-local {
        auth "local"
        compress none
        program "GNUTAR"
    }
    
    holdingdisk hd1 {
        directory "/amanda/holding"
        use 50 mbytes
        chunksize 1 mbyte
    }
    /etc/amanda/MyS3Conf/disklist

    Code:
    localhost /etc simple-gnutar-local
    amcheck runs and seems to be ok with my config.

    Code:
    Amanda Tape Server Host Check
    -----------------------------
    NOTE: Holding disk '/amanda/holding': 46653440 KB disk space available, using 51200 KB as requested
    '/etc/amanda/MyS3Conf/amanda.conf', line 17: warning: Global changerfile is deprecated, it must be set in the changer section
    slot 2: volume 'MyS3Config-2' is still active and cannot be overwritten
    slot 3: volume 'MyS3Config-3'
    Will write to volume 'MyS3Config-3' in slot 3.
    NOTE: skipping tape-writable test
    Server check took 1.645 seconds
    Amanda Backup Client Hosts Check
    --------------------------------
    Client check: 1 host checked in 0.018 seconds.  0 problems found.
    (brought to you by Amanda 3.4)
    amdump returns error code 1 when finished running, however some data finds it way to S3

    Picture of my s3-browser with the newly written data: http://i.imgur.com/2HgPBG8.jpg

    amreport returns the following error message.

    Code:
    amreport: Errors processing disklist at /usr/sbin/amreport line 588.
    amlabel and amdevcheck runs fine with SUCCESS as result.

    amadmin MyS3Conf find seems to be aware of the backup.

    Code:
    date                host      disk lv storage  pool     tape or file file part status
    2016-11-21 17:34:58 localhost /etc  1 MyS3Conf MyS3Conf MyS3Config-2    1  1/1 OK
    When trying to use amrecover it's only aware of directories.

    Code:
    amrecover MyS3Conf
    AMRECOVER Version 3.4. Contacting server on localhost ...
    220 zmandasrv01 AMANDA index server (3.4) ready.
    Setting restore date to today (2016-11-21)
    200 Working date set to 2016-11-21.
    200 Config set to MyS3Conf.
    501 Host zmandasrv01 is not in your disklist.
    Trying host zmandasrv01.hemma ...
    501 Host zmandasrv01.hemma is not in your disklist.
    Trying host zmandasrv01.hemma ...
    501 Host zmandasrv01.hemma is not in your disklist.
    Use the sethost command to choose a host to recover
    amrecover> sethost localhost
    200 Dump host set to localhost.
    amrecover> setdisk /etc
    200 Disk set to /etc.
    amrecover> add hosts
    File hosts doesn't exist in directory
    amrecover> ls
    2016-11-21-17-34-58 yum/
    2016-11-21-17-34-58 yum.repos.d/
    <SNIP>
    And when I try to recover the directories there seem to be some kind of device-config problem.

    Code:
    amrecover> add .
    Added dir /. at date 2016-11-21-17-34-58
    amrecover> extract
    
    Extracting files using tape drive tape:/dev/YOUR-TAPE-DEVICE-HERE on host localhost.
    The following tapes are needed: MyS3Config-2
    
    Extracting files using tape drive tape:/dev/YOUR-TAPE-DEVICE-HERE on host localhost.
    Load tape MyS3Config-2 now
    Continue [?/Y/n/s/d]? y
    Error setting device property 's3-secret-key' to value '<REDACTED>' on device 'tape:/dev/YOUR-TAPE-DEVICE-HERE': unknwon device-property
    Load tape MyS3Config-2 now
    Continue [?/Y/n/d]?
    Backup, report and recover works fine on the same server using local disk using the "MyConfig" works fine. I've tested to run amanda on both ubuntu 14.04 and rhel 7 and the behaviour is identical.

    Any advice on how to proceed?
    Last edited by np422; November 21st, 2016 at 08:15 AM. Reason: minor clarification

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,025

    Default

    Apply the attached amreport.txt patch to/usr/sbin/amreport tofic the amreport issue.

    In amrecover, tell it which device to use:
    settape "chg-multi:s3:EXTTEST-backups/MyS3Config1/slot-{01,02,03,04,05,06,07,08,09,10}"
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •