Results 1 to 4 of 4

Thread: Can't open tape device error - amcheck

  1. #1
    Join Date
    Feb 2016

    Default Can't open tape device error - amcheck

    I've just installed amanda backup server (amanda-server-2.6.1p2-9) on RHEL 6.6 and I'm getting this error when I run "amcheck DailySet1" or any "am" commands.

    ERROR: holding dir /dumps/amanda (No such file or directory), you must create a direcotry.
    slot 23: error reading label: Can't open tape device /dev/YOUR-TAPE-DEVICE-HERE:
    No such file or directory.
    Can't open tape device /dev/YOUR-TAPE-DEVICE-HERE: No such file or directory
    Insert tape into slot 24 and press return or type "NONE" to abort

    Does anyone know what thing(s) I need to setup before this will be resolved? I didn't see any instrucitons that would resolve in this the 15 minute setup instructions for the server.

  2. #2


    I am trying to Read / Write data into my HP LTO3 1X8 Autoloader Tape drive. I have the required drivers installed.

    When I ran rpm -qa | grep mt-st I got:

    Further when I ran cat /proc/scsi/scsi I got:

    Host: scsi1 Channel: 00 Id: 00 Lun: 00
    Vendor: NECVMWar Model: VMware IDE CDR10 Rev: 1.00
    Type: CD-ROM ANSI SCSI revision: 05
    Host: scsi2 Channel: 00 Id: 00 Lun: 00
    Vendor: VMware Model: Virtual disk Rev: 1.0
    Type: Direct-Access ANSI SCSI revision: 02
    Host: scsi2 Channel: 00 Id: 01 Lun: 00
    Vendor: HP Model: 1x8 autoloader Rev: 1.50
    Type: Medium Changer ANSI SCSI revision: 03
    Further tapeinfo -f /dev/sg2:

    Product Type: Medium Changer
    Vendor ID: 'HP '
    Product ID: '1x8 autoloader '
    Revision: '1.50'
    Attached Changer API: No
    SerialNumber: 'MXA0633052'
    SCSI ID: 1
    SCSI LUN: 0
    Ready: yes
    There is no device file st0 in my /dev location. So I tried to make it by some references from internet.

  3. #3


    I have the exact same problem. I haven't the faintest idea how to fix this, and I am sure I will have to waste time and money to fix this.

  4. #4
    Join Date
    Jul 2018


    I completely agree on with you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts