Results 1 to 5 of 5

Thread: FreeBSD needs some love in Amanda's configure script

  1. #1
    Join Date
    Apr 2008
    Location
    Goshen, KY
    Posts
    38

    Default FreeBSD needs some love in Amanda's configure script

    The Amanda configure script has several (4) places where it attempts to discover the FreeBSD release version. The tests fail to differentiate between release 1 and release 10.

    The enclosed patch works for me.
    Attached Files Attached Files

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    The configure file is generated by other software.

    The problem is that amanda is using an old version of libtool.
    I upgraded the libtool in amanda but I can't check if it fix the issue.

  3. #3
    Join Date
    Apr 2008
    Location
    Goshen, KY
    Posts
    38

    Default

    Jean-Louis,

    If you can let me know what I can do to test this, I'll be glad to help.

    I have several VM's available for testing.

    Hope I can help.

    David Boyd.

  4. #4
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    mkdir amanda-3.3.
    cd amanda-3.3
    svn checkout svn://svn.code.sf.net/p/amanda/code/amanda/branches/3_3
    ./autogen
    ./configure ....
    make

  5. #5
    Join Date
    Apr 2008
    Location
    Goshen, KY
    Posts
    38

    Default

    Jean-Louis,

    Sorry it took so long to get back to you.

    The changes that you made allows amanda to build properly on FreeBSD. There is still one test in "configure" that fails to detect FreeBSD 10, but it appears to be harmless.

    I have also tested the 3.3.9 release and that looks good as well.

    Thanks for your attention concerning this issue.

    David Boyd.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •