Results 1 to 4 of 4

Thread: Some disklists entries are not been backuped. What I'm doing wrong?

  1. #1

    Question Some disklists entries are not been backuped. What I'm doing wrong?

    Good morning!

    I'm having some trouble to configure Amanda 3.3.7 to backup a new CentOS 7.1 server, with a peculiar disk partition scheme and LVM use. I have had trough documentation, examples files, man pages and could not figure out what I'm doing wrong. I'm wanting to backup a server with RAID-1 disks. The logical disk provided by raid-1 have this setup:

    /dev/sda1 = /boot (primary partition, no LVM, ext4)
    /dev/sda2 = lmv2 partition, with a volume group named vg_fileserver

    Inside the LVM2 partition, we have 3 logical volumes:
    lv_swap = monted as swap
    lv_root = monted as /
    lv_data = monted as /data

    Here as some outputs from linux commands that show the disk setup:
    Code:
    [root@fileserver ~]# df -h
    Filesystem                         Size  Used Avail Use% Mounted on
    /dev/mapper/vg_fileserver-lv_root   50G  2.8G   44G   6% /
    devtmpfs                           908M     0  908M   0% /dev
    tmpfs                              918M     0  918M   0% /dev/shm
    tmpfs                              918M  101M  818M  11% /run
    tmpfs                              918M     0  918M   0% /sys/fs/cgroup
    /dev/sda1                          477M  192M  256M  43% /boot
    /dev/mapper/vg_fileserver-lv_data  1.8T  1.1T  558G  67% /data
    
    [root@fileserver ~]# pvs
      PV         VG            Fmt  Attr PSize PFree
      /dev/sda2  vg_fileserver lvm2 a--  1.82t 8.01g
    
    [root@fileserver ~]# vgs
      VG            #PV #LV #SN Attr   VSize VFree
      vg_fileserver   1   3   0 wz--n- 1.82t 8.01g
    
    [root@fileserver ~]# lvs
      LV      VG            Attr       LSize  Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
      lv_data vg_fileserver -wi-ao----  1.76t                                                    
      lv_root vg_fileserver -wi-ao---- 50.00g                                                    
      lv_swap vg_fileserver -wi-ao----  4.00g
    
    [root@fileserver ~]# lvdisplay 
      --- Logical volume ---
      LV Path                /dev/vg_fileserver/lv_root
      LV Name                lv_root
      VG Name                vg_fileserver
      LV UUID                BiaGSQ-GJNY-MS7y-Jzm5-ERAb-2YYD-Jz96AW
      LV Write Access        read/write
      LV Creation host, time localhost, 2015-06-23 13:21:28 -0300
      LV Status              available
      # open                 1
      LV Size                50.00 GiB
      Current LE             12800
      Segments               1
      Allocation             inherit
      Read ahead sectors     auto
      - currently set to     256
      Block device           253:0
       
      --- Logical volume ---
      LV Path                /dev/vg_fileserver/lv_data
      LV Name                lv_data
      VG Name                vg_fileserver
      LV UUID                rd6vdQ-nF19-n3WC-gVUi-Cdkr-h3Zo-Eo1u2H
      LV Write Access        read/write
      LV Creation host, time localhost, 2015-06-23 13:21:30 -0300
      LV Status              available
      # open                 1
      LV Size                1.76 TiB
      Current LE             460800
      Segments               1
      Allocation             inherit
      Read ahead sectors     auto
      - currently set to     256
      Block device           253:2
       
      --- Logical volume ---
      LV Path                /dev/vg_fileserver/lv_swap
      LV Name                lv_swap
      VG Name                vg_fileserver
      LV UUID                OHg2oY-FEYx-oKhY-mJgV-wDcs-EwTe-pSbqq7
      LV Write Access        read/write
      LV Creation host, time localhost, 2015-06-23 13:21:40 -0300
      LV Status              available
      # open                 2
      LV Size                4.00 GiB
      Current LE             1024
      Segments               1
      Allocation             inherit
      Read ahead sectors     auto
      - currently set to     256
      Block device           253:1
    Amanda server and client are configure with ssh, everything working as expected.

    The disklist entry for this server is:
    Code:
    fileserver.smsaude.com.br samba_raiz / {
       normal
       include "./" "./boot" "./data"
       exclude "./tmp" "./proc" "./dev" "./media" "./mnt" "./var/cache" "./var/run" "./run"
    } 5 local
    The problem is: JUST /boot and /data are being backuped, NOT the contents under /. For exemple, /etc are not in the backup.

    How can I configure Amanda to backup /, including /boot and /data?

    Thanks very much!

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Amanda never cross filesystem boundary, ypu must have one disklist entry for each partition

    fileserver.smsaude.com.br samba_raiz / {
    normal
    exclude "./tmp" "./proc" "./dev" "./media" "./mnt" "./var/cache" "./var/run" "./run"
    } 5 local
    fileserver.smsaude.com.br samba_raiz_boot /boot {
    normal
    } 5 local
    fileserver.smsaude.com.br samba_raiz_data /data {
    normal
    } 5 local

  3. #3

    Default

    Quote Originally Posted by martineau View Post
    Amanda never cross filesystem boundary, ypu must have one disklist entry for each partition

    fileserver.smsaude.com.br samba_raiz / {
    normal
    exclude "./tmp" "./proc" "./dev" "./media" "./mnt" "./var/cache" "./var/run" "./run"
    } 5 local
    fileserver.smsaude.com.br samba_raiz_boot /boot {
    normal
    } 5 local
    fileserver.smsaude.com.br samba_raiz_data /data {
    normal
    } 5 local
    Thanks very much, martineu! I'll try this on today backup.

    By the way, this information is on Amanda documentation? I don't remember that I have read this on any Amanda docs. Or maybe I just need to improve my english skills...

    Anyway: thanks again! I'll try today, at this night backup.

    Abrantes

  4. #4

    Default

    Just a follow-up: after martineu correction, every DLE was backuped as expected.

    And now I'm having another config issue: use one single tape drive with more than 1 tape (I'll post on another topic).

    Thanks again martineu!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •