Results 1 to 4 of 4

Thread: amcheck fail "selfcheck request failed: is not local"

  1. #1
    Join Date
    Jul 2014
    Posts
    2

    Default amcheck fail "selfcheck request failed: is not local"

    Hi All, I'm brand new in using amanda and starting my first install.

    So far I was able to succesfully make backups of local files and folders, but when add a remote host I get the following error on amcheck and amdump:

    Code:
    WARNING: example.com: selfcheck request failed: example.com: is not local
    Let's assume example.com is the hostname for the remote client.

    The remote host is correctly configured, I checked by running "amservice example.com bsdtcp noop < /dev/null" and getting "OPTIONS features=ffffffff9ffeffffffff7f;" from the server side so assumed everythig from that side is ok. This leaves me with a problem in the server configuration.

    The disklist is standarly configured:

    Code:
    localhost       /etc                            simple-gnutar-local
    localhost       /jboss                          simple-gnutar-local
    localhost       /usr/local/etc                  simple-gnutar-local
    localhost       /storage/backup-intranet        simple-gnutar-local
    example.com   /var/www/fe                     simple-gnutar-local
    example.com   /u                              simple-gnutar-local
    Firewall is down and SELINUX is disabled.

    I've crawled into source code and found this error "host: is not local" comes from common-src/local-security.c local_connect function which I guess is for localhost connecting, but in my install is using it to connect to the remote host and hence failing. This is the validation which is failing:

    Code:
    if (!g_str_equal(hostname, myhostname) &&
    	match("^localhost(\\.localdomain)?$", hostname) == 0) {
    	security_seterror(&rh->sech,
    	    _("%s: is not local"), hostname);
    	(*fn)(arg, &rh->sech, S_ERROR);
    	return;
        }
    Line 128 of https://github.com/zmanda/amanda/blob/master/common-src/local-security.c

    What am I missing? is there any configuration to refer to remote hosts instead of local?

    Thanks in advance!

    Mauro

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,045

    Default

    You can't use the 'local' auth to connect to a remote host.
    Use the 'bsdtcp' auth to connect to a remote host.

  3. #3
    Join Date
    Jul 2014
    Posts
    2

    Default

    Thank you so much!!!

    I completly missed that detail! its working now.

  4. #4

    Default

    I found them, thanks! This is great work, and will save me a lot of effort



    ________________
    Try out our free [url=http://www.learnalanguage.com/learn-dutch/]learn dutch[/url] and latest comptia [url=http://www.learnalanguage.com/learn-norwegian/]learn norwegian book[/url] training courses to get high flying success in final and [url=http://www.rasmussen.edu/]rasmussen[/url] exams
    Last edited by hibaaryan; February 17th, 2015 at 04:37 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •