Results 1 to 3 of 3

Thread: Solaris 11 - thd-806bec0: amandad: ľauth=bsdtcp: invalid service

  1. #1
    Join Date
    Apr 2014

    Default Solaris 11 - thd-806bec0: amandad: ľauth=bsdtcp: invalid service

    Anyone seen this error on Solaris 11. This comes out of the amanndad debug log when running amcheck. Amcheck errors with: WARNING: selfcheck request failed: EOF on read from

    Seems like it could be related to the service management. I'm sure someone may want additional info, just don't know what to send. Let me know and I will round it up.


  2. #2
    Join Date
    Apr 2014


    This is how I ran the configure before make.

    ./configure --with-user=amandabackup --with-group=disk --with-config=DailySet1 --without-server --with-gnutar=/usr/gnu/bin/tar --with-bsdtcp-security

    This line is in /etc/services

    amanda 10080/tcp # Amanda Backup

    service is online:

    root:~# svcs -a | grep -i amanda
    online Jun_18 svc:/network/amanda/tcp:default

    This is how amandad is configured in SMF:

    root:~# svcprop svc:/network/amanda/tcp:default
    general/complete astring
    general/enabled boolean true
    general/entity_stability astring External
    general/restarter fmri svc:/network/inetd:default
    manifestfiles/lib_svc_manifest_network_amanda-tcp_xml astring /lib/svc/manifest/network/amanda-tcp.xml
    inetconv/converted boolean true
    inetconv/source_line astring amanda\ stream\ tcp\ nowait\ amandabackup\ /usr/local/libexec/amanda/amandad\ amandad\ –auth=bsdtcp\ amdump
    inetconv/version integer 1
    inetd/endpoint_type astring stream
    inetd/isrpc boolean false
    inetd/name astring amanda
    inetd/proto astring tcp
    inetd/wait boolean false
    inetd_start/exec astring /usr/local/libexec/amanda/amandad\ –auth=bsdtcp\ amdump
    inetd_start/group astring disk
    inetd_start/timeout_seconds count 0
    inetd_start/type astring method
    inetd_start/use_profile boolean false
    inetd_start/user astring amandabackup
    inetd_disable/exec astring :kill
    inetd_disable/timeout_seconds count 0
    inetd_disable/type astring method
    tm_common_name/C ustring amanda
    restarter/auxiliary_state astring none
    restarter/next_state astring none
    restarter/state astring online
    restarter/state_timestamp time 1403120846.419969000
    inetd_state/cur_state integer 1
    inetd_state/next_state integer 13
    Last edited by pmorris; June 20th, 2014 at 05:06 AM.

  3. #3
    Join Date
    Apr 2014


    Finally worked out a solution using "ssh" instead of "bsdtcp".

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts