Results 1 to 9 of 9

Thread: Amanda 3.3.5-checking for GLIB - version >= 2.2.0... no

  1. #1
    Join Date
    Jun 2014
    Posts
    4

    Default Amanda 3.3.5-checking for GLIB - version >= 2.2.0... no

    CentOS 6.5 x86_64.
    yum package:
    glib2 2.26.1

    source packages:
    libffi-3.1
    pkg-config-0.27
    glib-2.40.0

    I have been beating my head against this wall all day. Amanda doesn't recognize a package installed via yum. So I went and got a glib 2.40.0 package from source which required some other source packages as dependencies. (Namely libffi and pkg-config). Unfortunately pkg-config also has a dependency of glib. Fortunately, pkg-config comes with glib-2.26.1 embedded in the package. No matter how I get glib on the system though, Amanda never recognizes it. All of my research suggests there is a config file somewhere which will allow me to designate proper path for glib. I cannot for the life of me find said config file. Any ideas on why Amanda hates me so much?

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    What are you doing? What is the exact error message you get?

  3. #3
    Join Date
    Jun 2014
    Posts
    4

    Default

    This is the error after running ./configure :

    checking for GLIB - version >= 2.2.0... no
    *** Could not run GLIB test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means GLIB is incorrectly installed.
    configure: error: glib not found or too old; See <zamanda.website>/Installation for help

  4. #4
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Do you checked in the 'config.log' for the error as the message told you to do?
    What is the compilation or execution error message form config.log?

    Maybe you did not install the 'glib2-devel' package?

  5. #5
    Join Date
    Jun 2014
    Posts
    4

    Default

    [root@<servername> amanda-3.3.5]# cat config.log | grep glib
    | /* This code succeeds on glibc 2.8, OpenBSD 4.0, Cygwin, mingw,
    | /* This code succeeds on glibc 2.8, mingw,
    | /* This code succeeds on glibc 2.8 and fails on Cygwin 1.7.0. */
    | /* This code fails on glibc 2.11. */
    | /* This code dumps core on glibc 2.14. */
    | /* glibc uses struct timezone * rather than the POSIX void *
    | since the glibc definition is actually more typesafe, it is
    conftest.c:546:18: error: glib.h: No such file or directory
    conftest.c:552: error: 'glib_major_version' undeclared (first use in this function)
    conftest.c:552: error: 'glib_minor_version' undeclared (first use in this function)
    conftest.c:552: error: 'glib_micro_version' undeclared (first use in this function)
    | #include <glib.h>
    | return ((glib_major_version) || (glib_minor_version) || (glib_micro_version));
    configure:42708: error: glib not found or too old; See <zamandawiki>/index.php/Installation for help
    pkglibexecdir='${libexecdir}/${PACKAGE}'

  6. #6
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    It told you it do not find glib.h

    What to do????
    Install the package which contains glib.h

    As I already told you, do you installed the glib2-devel package? DO IT!!!
    You will require many more devel packages to compile amanda.

  7. #7
    Join Date
    Jun 2014
    Posts
    4

    Default

    thank you. More dependency issues. But I will work through them as needed. Thank you again.

  8. #8
    Join Date
    Apr 2014
    Location
    Seattle, Washington, USA
    Posts
    2

    Default

    I am trying to configure Amanda 3.3.1 on Debian Linux 7.5 (Wheezy) and I am running into the same problem.



    ./configure --sysconfdir=/etc --localstatedir=/var/amanda --with-ssh-security
    ...
    It failed with checking for GLIB - version >= 2.2.0... no
    *** Could not run GLIB test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means GLIB is incorrectly installed.
    configure: error: glib not found or too old; See wiki.zmanda.com/index.php/Installation for help

    I think configure is wrong:

    checking for GLIB - version >= 2.2.0... no
    *** Could not run GLIB test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means GLIB is incorrectly installed.
    configure: error: glib not found or too old; See wiki.zmanda.com/index.php/Installation for help
    jsilverman@kir01gans002:~/amanda-3.3.1$ dpkg -l glib\*
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Architecture Description
    +++-============================-===================-===================-================================================== ===========
    un glibc-2.13-1 <none> (no description available)
    un glibc-doc <none> (no description available)
    jsilverman@kir01gans002:~/amanda-3.3.1$

    wiki.zmanda.com/index.php/Installation/Installing_Amanda_Source says

    Common Problems

    Glibc is not where ./configure expects it to be. This can also be a side effect of ./configure not finding pkg-config. Different platforms hide pkg-config in different locations. use:
    PKG_CONFIG=/your/location/pkg-config ./configure
    to specify your path.

    pgk-config is in /usr/bin

    jsilverman@kir01gans002:~/amanda-3.3.1$ dpkg -l glib\*
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Architecture Description
    +++-============================-===================-===================-================================================== ===========
    un glibc-2.13-1 <none> (no description available)
    un glibc-doc <none> (no description available)
    jsilverman@kir01gans002:~/amanda-3.3.1$

    forums.zmanda.com/showthread.php?5448-Amanda-3-3-5-checking-for-GLIB-version-gt-2-2-0-no says install glib2-devel. So try it. apt-get says I have the latest version.

    jsilverman@kir01gans002:~/amanda-3.3.1$ dpkg -l libglib2.0-0
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Architecture Description
    +++-============================-===================-===================-================================================== ===========
    ii libglib2.0-0:amd64 2.33.12+really2.32. amd64 GLib library of C routines
    jsilverman@kir01gans002:~/amanda-3.3.1$ dpkg -L libglib2.0-0
    /.
    /lib
    /lib/x86_64-linux-gnu
    /lib/x86_64-linux-gnu/libglib-2.0.so.0.3200.4
    /usr
    /usr/lib
    /usr/lib/x86_64-linux-gnu
    /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.3200.4
    /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0.3200.4
    /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0.3200.4
    /usr/lib/x86_64-linux-gnu/gio
    /usr/lib/x86_64-linux-gnu/gio/modules
    /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0.3200.4
    /usr/lib/x86_64-linux-gnu/glib-2.0
    /usr/lib/x86_64-linux-gnu/glib-2.0/gio-querymodules
    /usr/lib/x86_64-linux-gnu/glib-2.0/glib-compile-resources
    /usr/lib/x86_64-linux-gnu/glib-2.0/glib-compile-schemas
    /usr/share
    /usr/share/doc
    /usr/share/doc/libglib2.0-0
    /usr/share/doc/libglib2.0-0/copyright
    /usr/share/doc/libglib2.0-0/changelog.gz
    /usr/share/doc/libglib2.0-0/ChangeLog.pre-2-2.gz
    /usr/share/doc/libglib2.0-0/NEWS.pre-1-3.gz
    /usr/share/doc/libglib2.0-0/ChangeLog.pre-2-0.gz
    /usr/share/doc/libglib2.0-0/README.gz
    /usr/share/doc/libglib2.0-0/ChangeLog.pre-1-2.gz
    /usr/share/doc/libglib2.0-0/NEWS.gz
    /usr/share/doc/libglib2.0-0/changelog.Debian.gz
    /usr/share/doc/libglib2.0-0/AUTHORS
    /usr/share/lintian
    /usr/share/lintian/overrides
    /usr/share/lintian/overrides/libglib2.0-0
    /usr/share/glib-2.0
    /usr/share/glib-2.0/schemas
    /lib/x86_64-linux-gnu/libglib-2.0.so.0
    /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
    /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0
    /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0
    /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
    jsilverman@kir01gans002:~/amanda-3.3.1$
    jsilverman@kir01gans002:~/amanda-3.3.1$ lsb_release -a
    No LSB modules are available.
    Distributor ID: Debian
    Description: Debian GNU/Linux 7.5 (wheezy)
    Release: 7.5
    Codename: wheezy
    jsilverman@kir01gans002:~/amanda-3.3.1$

    However, I can see why configure might be confused:

    jsilverman@kir01gans002:~/amanda-3.3.1$ pkg-config --list-all
    udev udev - udev
    usbutils usbutils - USB device database
    libtasn1 libtasn1 - Library for ASN.1 and DER manipulation
    libssh2 libssh2 - Library for SSH-based communication
    gnutls GnuTLS - Transport Security Layer implementation for the GNU system
    p11-kit-1 p11-kit - Library and proxy module for properly loading and sharing PKCS
    openssl OpenSSL - Secure Sockets Layer and cryptography libraries and tools
    libpcrecpp libpcrecpp - PCRECPP - C++ wrapper for PCRE
    libffi libffi - Library supporting Foreign Function Interfaces
    librtmp librtmp - RTMP implementation
    xkeyboard-config XKeyboardConfig - X Keyboard configuration data
    python-2.7-dbg Python - Python library
    libcrypto OpenSSL-libcrypto - OpenSSL cryptography library
    zlib zlib - zlib compression library
    libbsd libbsd - Utility functions from BSD systems
    com_err com_err - Common error description library
    libpcre libpcre - PCRE - Perl compatible regular expressions C library with 8 bit character support
    python-2.7 Python - Python library
    libbsd-overlay libbsd - Utility functions from BSD systems (overlay)
    bash-completion bash-completion - programmable completion for the bash shell
    libidn Libidn - IETF stringprep, nameprep, punycode, IDNA text processing.
    libcurl libcurl - Library to transfer files with ftp, http, etc.
    expat expat - expat XML parser
    gnutls-extra GnuTLS-extra - Additional add-ons for GnuTLS licensed under GPL
    libpcreposix libpcreposix - PCREPosix - Posix compatible interface to libpcre
    iso-codes iso-codes - ISO country, language, script and currency codes and translations
    libssl OpenSSL - Secure Sockets Layer and cryptography libraries
    shared-mime-info shared-mime-info - Freedesktop common MIME database
    jsilverman@kir01gans002:~/amanda-3.3.1$

    I am using amanda-3.3.1 because that's the version that comes with this version of Debian - I am trying to be as consistent as possible. I think I may try building 3.3.5 next in a different directory and see what happens.

  9. #9
    Join Date
    Apr 2014
    Location
    Seattle, Washington, USA
    Posts
    2

    Default I have the same problem with 3.3.5

    I tried the same procedure with 3.3.5 and I get the same error message.

    ./configure --sysconfdir=/etc --localstatedir=/var/amanda --with-ssh-security
    ...
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.7... yes
    checking for GLIB - version >= 2.2.0... no
    *** Could not run GLIB test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means GLIB is incorrectly installed.
    configure: error: glib not found or too old; See wiki.zmanda.com/index.php/Installation for help
    jsilverman@kir01gans002:~/amanda-3.3.5$

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •