Results 1 to 3 of 3

Thread: selfcheck request failed: amanda/udp unknown protocol

  1. #1
    Join Date
    Feb 2014
    Posts
    7

    Default selfcheck request failed: amanda/udp unknown protocol

    Hi
    I am facing issues in amcheck.Pls find the details of my configuration.

    Both server and client is Solaris 10.
    Server IP : 10.xxx.xx.xxx
    Client IP : 10.yy.yy.yyy

    ===Result of amservice===
    bash-3.2$ /newAmanda/home/sbin/amservice 10.yy.yy.yyy bsdtcp noop </dev/null
    OPTIONS features=ffffffff9efefbffffffffff00;

    ===Result of amcheck====
    Amanda Tape Server Host Check
    -----------------------------
    ERROR: no tapetype specified; you must give a value for the 'tapetype' parameter
    NOTE: tapelist will be created on the next run.
    Holding disk /newAmanda/holding: 25211904 kB disk space available, using 51200 kB as requested
    slot 1: Can't read label: Error loading device header -- unlabeled volume?
    Will write label 'MyData01' to new volume in slot 1.
    NOTE: skipping tape-writable test
    NOTE: host info dir /newAmanda/state/curinfo/10.yy.yy.yyy does not exist
    NOTE: it will be created on the next run.
    NOTE: index dir /newAmanda/state/index/10.yy.yy.yyy does not exist
    NOTE: it will be created on the next run.
    Server check took 0.149 seconds

    Amanda Backup Client Hosts Check
    --------------------------------
    WARNING: 10.yy.yy.yyy: selfcheck request failed: amanda/udp unknown protocol
    Client check: 1 host checked in 10.002 seconds. 1 problem found.


    ===My Server configuration files===
    ==amanda.conf==

    org "MyConfig"
    infofile "/newAmanda/state/curinfo"
    logdir "/newAmanda/state/log"
    indexdir "/newAmanda/state/index"
    dumpuser "amanda"

    tpchanger "chg-disk:/newAmanda/vtapes"
    labelstr "MyData[0-9][0-9]"
    autolabel "MyData%%" EMPTY VOLUME_ERROR
    tapecycle 4
    dumpcycle 3 days
    amrecover_changer "changer"


    holdingdisk hd1 {
    directory "/newAmanda/holding"
    use 50 Mb
    chunksize 1 mbyte
    }

    define tapetype HPDAT-40 {
    comment "HP StorageWorks DAT40 USB"
    length 17021 mbytes
    filemark 403 kbytes
    speed 1491 kps
    }

    define dumptype global {
    comment "Global definitions"
    auth "bsdtcp"
    # This is quite useful for setting global parameters, so you don't have
    # to type them everywhere. All dumptype definitions in this sample file
    # do include these definitions, either directly or indirectly.
    # There's nothing special about the name `global'; if you create any
    # dumptype that does not contain the word `global' or the name of any
    # other dumptype that contains it, these definitions won't apply.
    # Note that these definitions may be overridden in other
    # dumptypes, if the redefinitions appear *after* the `global'
    # dumptype name.
    # You may want to use this for globally enabling or disabling
    # indexing, recording, etc. Some examples:
    # index yes
    # record no
    # split_diskbuffer "/raid/amanda"
    # fallback_splitsize 64m
    }

    define dumptype root-tar {
    program "GNUTAR"
    comment "root partition dump with tar"
    #options index, exclude-list "/etc/amanda/fullback/fullback.exclude"
    priority high
    }


    ===amandaclient.conf===


    # amanda.conf - sample Amanda client configuration file.
    #
    # This file normally goes in /amanda/home/etc/amanda/amanda-client.conf.
    #

    conf "MyConfig" # your config name
    10.xxx.xx.xxx "@DEFAULT_SERVER@" # your amindexd server
    10.xxx.xx.xxx "@DEFAULT_TAPE_SERVER@" # your amidxtaped server
    tapedev "@EXAMPLE_TAPEDEV@" # your tape device

    #tapedev "tape:/dev/YOUR-TAPE-DEVICE-HERE" # your tape device
    # if not set, Use configure or ask server.
    # if set to empty string "", ask server
    # amrecover will use the changer if set to the value
    # of 'amrecover_changer' in the server amanda.conf.

    # auth - authentication scheme to use between server and client.
    # Valid values are "bsd", "bsdudp", "bsdtcp", "krb5", "local",
    # "rsh" and "ssh".
    # Default: [auth "bsdtcp"]
    auth "bsdtcp"

    #ssh_keys "" # your ssh keys file if you use ssh auth

    ===/etc/services - Server ===

    amanda 10080/tcp
    amandaidx 10082/tcp
    amidxtape 10083/tcp

    ===/etc/services - Client ===
    amanda 10080/tcp
    amandaidx 10082/tcp
    amidxtape 10083/tcp

    Could you please help me to figure out the issue. I am stucked on the configuration due to this issue.

    Thanks in advance
    Abilash KP
    Last edited by Abilash; March 5th, 2014 at 06:53 AM.

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,045

    Default

    You are using the "bsd" auth, you should use the "bsdtcp" auth

    run 'amadmin CONF disklist' to find which auth is used.
    All DLEs must have the same auth.

  3. #3
    Join Date
    Feb 2014
    Posts
    7

    Default

    Hi Martineau

    Thanks a lot
    It worked!.

    Regards
    Abilash

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •