Results 1 to 6 of 6

Thread: unable to run "amrecover DailySet1". Getting NAK message.

  1. #1

    Angry unable to run "amrecover DailySet1". Getting NAK message.

    Hi guys,
    I have been working on "amanda-backup_server-3.3.2-1.rhel6.x86_64".
    So far I am able to set it up successfully. I am able to take the backup of a client system.

    But when i run the command to recover, I get error:
    [[email protected] ~]# amrecover DailySet1
    AMRECOVER Version 3.3.2. Contacting server on amanda.example.com ...
    NAK: amindexd: invalid service, add 'amindexd' as argument to amandad


    I have not found any working solution out there.
    I hope posting directly in amanda forums will give me some relief.

    I am posting my "amandaclient" file for your reference.
    [[email protected] ~]# cat /etc/xinetd.d/amandaclient
    # default: on
    #
    # description: The Amanda backup client should be enabled for systems
    # which will be backed up by an Amanda backup server.

    service amanda
    {
    disable = no
    flags = IPv4
    socket_type = stream
    protocol = tcp
    wait = no
    user = amandabackup
    group = disk
    groups = yes
    server = /usr/libexec/amanda/amandad
    server_args = -auth=bsdtcp amdump amindexd amidxtaped
    }


    From my side, I think it is fine.

    Can anyone tell me what to do next to get it running !!!

    Thanks.

  2. #2
    Join Date
    Apr 2014
    Posts
    9

    Default

    I'm running into the same problem. RHEL6.5, Amanda 3.3.5. The error message doesn't seem to address the actual problem. Have gone thru many different entries and permission setting on the .amandahosts file and different <host> <user> <command> settings on both client and host. Is there a description of the .amandahosts files purpose and usage and how the permissions are granted and how the authentication is handled somwhere that I'm overlooking?

    Thanks

  3. #3
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    What's your xinetd file on the amanda server? Do you restarted xinetd?
    Which auth are you using? post the amrecover debug file.
    Whats in /etc/amanda/amanda-client.conf on the client?

  4. #4
    Join Date
    Apr 2014
    Posts
    9

    Default Requested files:

    Quote Originally Posted by martineau View Post
    What's your xinetd file on the amanda server? Do you restarted xinetd?
    Which auth are you using? post the amrecover debug file.
    Whats in /etc/amanda/amanda-client.conf on the client?
    Martineau,

    As this is the first time I've delt with amanda I don't have the background understanding of the how the system componenets come together. I used the 15 Min. tutorial to get this far. Had to make a few straight forward adjustments because of the differences in versions. Is there a document for version 3.3.x similar to the one for 2.5.x? I haven't found one yet, so a pointer to one would be helpful. If the concepts are the same from 2.5 to 3.3 I guess I could just bone up on those.

    Anyhow...

    The files posted here are the state of things as they are when I just figured i just didn't get what the heck was suppose to be happening. I have restarted xinetd on both client and host and ran amrecover as root on both client and host. Both get the same error. And as a bonus no amrecover.*.debug files are generated. If I execute the amrecover command as the amandabackup user a debug file is created but it just tells me I'm executing the command as amandabackup user and not root. Soo... onward thru the fog...




    ----------- server host files start here------------------


    [[email protected] ~]# cat /etc/xinetd.d/amandaserver
    # default: on
    #
    # description: Amanda services for Amanda server and client.
    #

    service amanda
    {
    disable = no
    flags = IPv4
    socket_type = stream
    protocol = tcp
    wait = no
    user = amandabackup
    group = disk
    groups = yes
    server = /usr/libexec/amanda/amandad
    server_args = -auth=bsdtcp amdump amindexd amidxtaped
    }
    [[email protected] ~]#



    [[email protected] ~]# cat /var/lib/amanda/.amandahosts
    neo.as.utexas.edu root amindexd amidxtaped
    zmanda.as.utexas.edu amandabackup amdump
    zmanda.as.utexas.edu root amindexd amidxtaped
    localhost.localdomain root amindexd amidxtaped
    localhost root amindexd amidxtaped
    [[email protected] ~]#

    [[email protected] ~]# amrecover
    AMRECOVER Version 3.3.5. Contacting server on localhost ...
    NAK: user root from localhost is not allowed to execute the service amindexd: /var/lib/amanda/.amandahosts: incorrect permissions; file must be accessible only by its owner
    [[email protected] ~]# ls /var/log/amanda/client
    DailySet1 DataSet1
    [[email protected] ~]#



    -------------------Client files start here--------------------------

    #
    # amanda-client.conf - sample Amanda client configuration file.
    #
    # This file normally goes in /etc/amanda/amanda-client.conf.
    #

    conf "DailySet1" # your config name

    index_server "zmanda.as.utexas.edu" # your amindexd server
    tape_server "zmanda.as.utexas.edu" # your amidxtaped server
    tapedev "/dev/null" # your tape device
    # if not set, Use configure or ask server.
    # if set to empty string "", ask server
    # amrecover will use the changer if set to the value
    # of 'amrecover_changer' in the server amanda.conf.

    # auth - authentication scheme to use between server and client.
    # Valid values are "bsd", "bsdudp", "bsdtcp", "krb5", "local",
    # "rsh" and "ssh".
    # Default: [auth "bsdtcp"]
    auth "bsdtcp"

    ssh_keys "" # your ssh keys file if you use ssh auth

    [[email protected] amanda]#
    [[email protected] ~]# cat /etc/xinetd.d/amandaclient
    # default: on
    #
    # description: The Amanda backup client should be enabled for systems
    # which will be backed up by an Amanda backup server.

    service amanda
    {
    disable = no
    flags = IPv4
    socket_type = stream
    protocol = tcp
    wait = no
    user = amandabackup
    group = disk
    groups = yes
    server = /usr/libexec/amanda/amandad
    server_args = -auth=bsdtcp amdump amindexd amidxtaped
    }
    [[email protected] ~]#
    [[email protected] ~]# cat /var/lib/amanda/.amandahosts
    zmanda.as.utexas.edu amandabackup amdump
    zmanda.as.utexas.edu root amindex amidxtaped
    neo.as.utexas.edu root amindexd amidxtaped
    [[email protected] ~]#


    [[email protected] test-recovery]# amrecover
    AMRECOVER Version 3.3.5. Contacting server on zmanda.as.utexas.edu ...
    NAK: user root from neo.as.utexas.edu is not allowed to execute the service amindexd: /var/lib/amanda/.amandahosts: incorrect permissions; file must be accessible only by its owner
    [[email protected] test-recovery]# ls /var/log/amanda/client
    DailySet1 DataSet1
    [[email protected] test-recovery]#

  5. #5
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Quote Originally Posted by pmorris View Post

    [[email protected] ~]# amrecover
    AMRECOVER Version 3.3.5. Contacting server on localhost ...
    NAK: user root from localhost is not allowed to execute the service amindexd: /var/lib/amanda/.amandahosts: incorrect permissions; file must be accessible only by its owner
    [[email protected] ~]# ls /var/log/amanda/client
    DailySet1 DataSet1
    [[email protected] ~]#
    chown amandabackup /var/lib/amanda/.amandahosts; chmod 600 /var/lib/amanda/.amandahosts

  6. #6
    Join Date
    Apr 2014
    Posts
    9

    Lightbulb YEP... I'm officially ignernt!

    Quote Originally Posted by martineau View Post
    chown amandabackup /var/lib/amanda/.amandahosts; chmod 600 /var/lib/amanda/.amandahosts
    DUH!!! I found that little ditty in another one of your posts from way back. I dId it on the client not the server. So now that makes sense, it is a server side error not a client side.

    Thanks for the kick. Hope it didn't take too much of your day!

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •