Results 1 to 2 of 2

Thread: Header issue on 3.1.1 (Solaris 9 SPARC)

  1. #1
    Join Date
    Aug 2013
    Posts
    1

    Default Header issue on 3.1.1 (Solaris 9 SPARC)

    Hi,

    I've just installed Amanda 3.1.1 which works fine apart from one problem, the dump files have invalid headers which look like this:

    amrestore --config Dagelijks -p /dev/rmt/1hn orap /home >test
    Restoring from tape 000013 starting with file 1.
    amrestore: 1: skipping split dumpfile: date 20130808142640 host orap disk /boot part 1/UNKNOWN lev 1 comp N program /bin/tar

    amrestore then exits with status 0, the file 'test' is empty


    However I know the tar file is on the tape:

    amadmin Dagelijks find orap /home
    date host disk lv tape or file file part status
    2013-08-08 14:26:40 orap /home 0 000013 2 1/1 OK


    If I execute

    amrestore --config Dagelijks -p /dev/rmt/1hn -f 2 >test
    Restoring from tape 000013 starting with file 2.
    amrestore: 2: restoring split dumpfile: date 20130808142640 host orap disk /home part 1/UNKNOWN lev 0 comp N program /bin/tar

    this exits successfully and the file 'test' is a valid tar file which contains the correct files

    I'm using a SunStore L8 tape library with an LTO-2 drive

    How do I enable debugging to get more info on the root cause of this problem?

    TIA

    Shaun

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    This is an old version and an old bug. As you found, the work around is to positioning the tape to the file you want with the -f argument of amrestore.

    You should try amfetchdump instead of amrestore.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •