Results 1 to 9 of 9

Thread: Backup MooseFS partition.

  1. #1
    Join Date
    Jun 2013
    Posts
    6

    Default Backup MooseFS partition.

    Hi,

    I have a problem with Backup MooseFS partition that is mounted as a client to a server Debian Wheezy.
    The problem is that all the local partitions, NFS partitions that are mounted on the server, create a incremental backup but the partition MooseFS doing full backup.
    Client and server use version 3.3.3 Amanda.

    Regards.

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Try to set the 'CHECK-DEVICE' property of amgtar to "NO"

    Jean-Louis

  3. #3
    Join Date
    Jun 2013
    Posts
    6

    Default

    Quote Originally Posted by martineau View Post
    Try to set the 'CHECK-DEVICE' property of amgtar to "NO"

    Jean-Louis
    It does not work and in the logs I have:
    Code:
    INFO amdump amdump pid 15295
    FATAL planner errors processing config file
    FATAL driver errors processing config file
    This is my config on server:

    Code:
    org "DailySet1"
    
    dumpuser "amandabackup"
    
    logdir   "/etc/amanda/DailySet1/logs"                # log directory
    infofile "/etc/amanda/DailySet1/curinfo"             # database filename
    indexdir "/etc/amanda/DailySet1/index"               # index directory
    tapelist "/etc/amanda/DailySet1/tapelist"            # list of used tapes
    
    tapecycle 60 tapes
    runtapes 1
    
    dumpcycle 7 days
    runspercycle 7
    
    tapetype HARDDISK
    labelstr "^DailySet1-[0-9][0-9]*$"
    tpchanger "chg-disk"
    changerfile "/etc/amanda/DailySet1/changer"  # needed by amlabel
    changerdev "/dev/null"
    
    tapedev "file:/data/backup/space/vtapes/DailySet1/slots"
    
    amrecover-changer "chg-disk"
    
    netusage 51200 Kbps
    
    define tapetype HARDDISK {
            comment "Backup to HD"
            length 500 gbytes
            part_size 1 gbytes
            part_cache_type none
    }
    
    # comment holding disk section if needed
    holdingdisk hd1 {
             directory "/data/backup/dumps/"
    }
    
    define application-tool app_amgtar {
         comment "amgtar"
         plugin  "amgtar"
         property "CHECK-DEVICE" "no"
    }
    
    # to be used by any other dumptype
    define dumptype global {
            comment "Global definitions"
            index yes
            record yes
            auth "bsdtcp"
    }
    
    define dumptype daily {
            global
            comment "daily dumptype"
            compress client fast
            program "GNUTAR"
            strategy standard
            priority high
            holdingdisk no
            exclude list "/etc/amanda/DailySet1/global-debian-exclude.list"
            application "app_amgtar"
    }

  4. #4
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    On which line? you should have it in the email report.
    Or run 'amcheck CONF'.

  5. #5
    Join Date
    Jun 2013
    Posts
    6

    Default

    Problem with amgtar solved.

    I had to change define dump daily on:
    Code:
    define dumptype daily {
            global
            comment "daily dumptype"
            compress client fast
            program "APPLICATION"
            application "app_amgtar"
    #       program "GNUTAR"
            strategy standard
            priority high
            holdingdisk no
            exclude list "/etc/amanda/DailySet1ClusterMFS1/global-debian-exclude.list"
    }
    Now test the backup data from MooseFS.

  6. #6
    Join Date
    Aug 2008
    Posts
    184

    Default

    Great. Please do keep this thread updated with your findings. Many others would be interested in backing up data from MooseFS using Amanda.

  7. #7
    Join Date
    Jun 2013
    Posts
    6

    Default

    Setting property "CHECK-DEVICE" "no" was useless and amanda still creates a full backup
    Any other suggestions?

  8. #8
    Jeff Guest

    Default

    Quote Originally Posted by andypl View Post
    Setting property "CHECK-DEVICE" "no" was useless and amanda still creates a full backup
    Any other suggestions?
    Andy,

    You may want to try forcing an incremental backup on the DLE with your next attempt. Can you try running the following command (as amandabackup)?

    $ amdump -o DUMPTYPE:daily:strategy=nofull <backupset> localhost <disk>

    As a full has already been taken, an incremental should kick off, provided nothing else is at work here.

    Jeff

  9. #9
    Join Date
    Jun 2013
    Posts
    6

    Default

    I do not know why but Amanda did the first two full backups and then incremental already doing correctly.
    We'll see next week will properly complete backup.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •