Results 1 to 2 of 2

Thread: Perl_Gthr_key_ptr error on fresh install of Amanda 3.3.3 on Debian 7 Wheezy

  1. #1
    Join Date
    Jun 2013
    Posts
    11

    Default Perl_Gthr_key_ptr error on fresh install of Amanda 3.3.3 on Debian 7 Wheezy

    This week I've been trying to bring up a new Amanda Server to do backups for the small company I work at. So far I've been successful at installing Debian 7, and installing the Amanda 3.3.3 package from: [url]http://www.zmanda.com/downloads/community/Amanda/3.3.3/Debian-6.0/[/url] I had already tried installing Amanda using apt-get, however it ran into many more problems, so I restarted again yesterday.

    I've been following the guide found at: [url]http://wiki.zmanda.com/index.php/GSWA/Build_a_Basic_Configuration[/url]
    So far so good, until I've reached the "Check" section. I can try to run the following command with the results bellow:

    Code:
    amandabackup@amanda:~$ /usr/sbin/amcheck TestConfig
    Amanda Tape Server Host Check
    -----------------------------
    NOTE: tapelist will be created on the next run.
    Holding disk /amanda/holding: 8965500928 kB disk space available, using 51200 kB as requested
    /usr/bin/perl: symbol lookup error: /usr/local/share/perl/5.10.1/auto/Amanda/Debug/libDebug.so: undefined symbol: Perl_Gthr_key_ptr
    NOTE: host info dir /amanda/state/curinfo/localhost does not exist
    NOTE: it will be created on the next run.
    NOTE: index dir /amanda/state/index/localhost does not exist
    NOTE: it will be created on the next run.
    Server check took 0.026 seconds
    
    Amanda Backup Client Hosts Check
    --------------------------------
    Client check: 1 host checked in 2.031 seconds.  0 problems found.
    
    (brought to you by Amanda 3.3.3)
    I've spent all morning googling this Perl_Gthr_key_ptr, and I found that I have a newer version of perl installed, as shown bellow:

    Code:
    amandabackup@amanda:~$ perl -v
    
    This is perl 5, version 14, subversion 2 (v5.14.2) built for x86_64-linux-gnu-thread-multi
    (with 80 registered patches, see perl -V for more detail)
    I've also tried installing apt-get install libperl-dev and libxml-simple-perl without any luck.

    I'm thinking the package of Amanda is trying to use an outdated version of perl. How can I fix this problem? I would rather just point Amanda to the newer installation of perl, instead of force installing an outdated version perl or restarting from scratch on debian 6.

    Thank you!!!

    Alex

  2. #2
    Join Date
    Jun 2013
    Posts
    11

    Default

    I dropped Debian for Ubuntu 12.04. I used the appropriate Amanda .deb packaged, and the perl issues are solved.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •