Results 1 to 3 of 3

Thread: Report Issues

  1. #1
    Join Date
    Jun 2013
    Location
    Dearborn, MI
    Posts
    2

    Question Report Issues

    I downloaded and installed 3.3.3.deb to Ubuntu 12.04, configured a backup, configured a client, and everything works. I already had a printer installed and working, but when I tried to generate a paper report, I get the error: lbl-templ set but no LPR command defined. You should reconfigure amanda and make sure it finds a lpr or lp command. I cannot find anything in the documentation on how to do this. I commented out the printer in the config file, so that it would use the default printer, but this had no effect. Digging through the code, it looks like the printer should be auto discovered, but this is not working. Lp and lpr are both installed. I am not sure where to go next. I have done internet searches and have not really found an answer. There is nothing in the documentation that I can find that tells me how to reconfigure it either. Any help would be appreciated. Thank you.

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    The lpr or lp command was not found while amanda was compiled, it can't be found at run time.

    You can add it to the Amanda/constants.pm file:
    $LPR = "/usr/bin/lpr";
    $LPRFLAG = "";

  3. #3
    Join Date
    Jun 2013
    Location
    Dearborn, MI
    Posts
    2

    Default

    Thank you. That fixed it, although amcheck still complains.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •