Results 1 to 3 of 3

Thread: How to install Amanda 3.3.x on Ubuntu 12.04

  1. #1
    Join Date
    Apr 2013
    Posts
    2

    Default How to install Amanda 3.3.x on Ubuntu 12.04

    Server:
    Ubuntu 12.04 (32bit) VM

    Software:
    Downloaded: [url]http://www.zmanda.com/downloads/community/Amanda/3.3.3/Ubuntu-12.04/amanda-backup-server_3.3.3-1Ubuntu1204_i386.deb[/url]

    Install Procedure:
    I have reviewed the install procedure here and am still confused:
    [url]http://wiki.zmanda.com/index.php/Amanda_packages_from_Zmanda_downloads_page[/url]

    Question:
    Where is the install procedure? I unzipped the .deb file but I do not see any install scripts...
    Can someone please point me in the right direction?
    Are there any prerequisites to the install procedure?

    Thanks in advance.

  2. #2

    Default

    Once you've downloaded the package, in your case the amanda-backup-server_3.3.3-1Ubuntu1204_i386.deb (i use the amd64 version so remember to change that in the commands below), you need to install all the dependencies first.

    Run the following command :

    Code:
    # dpkg -I amanda-backup-server_3.3.3-1Ubuntu1204_amd64.deb
    The output should look something like this:

    Code:
       new debian package, version 2.0.
            size 2868968 bytes: control archive= 20447 bytes.
                  1035 bytes,    22 lines      control
                  22293 bytes,   303 lines      md5sums
                  23159 bytes,   660 lines   *  postinst             #!/bin/sh
                  11180 bytes,   384 lines   *  postrm               #!/bin/sh
                  20739 bytes,   587 lines   *  preinst              #!/bin/sh
                  375 bytes,    10 lines      shlibs
             Package: amanda-backup-server
             Source: amanda
             Version: 3.3.3-1Ubuntu1204
             Architecture: amd64
             Maintainer: Zmanda Inc <support@zmanda.com>
             Installed-Size: 9856
             Depends: ca-certificates, xinetd, perl (>= 5.6.0), gettext, mailx | bsd-mailx, libc6 (>= 2.14), libcurl3 (>= 7.16.2-1), libglib2.0-0 (>=                                                  
             2.31.8), libreadline6 (>= 6.0), libssl1.0.0 (>= 1.0.0)
             Suggests: gnuplot-nox | gnuplot
             Conflicts: amanda-backup-client, amanda-client, amanda-common, amanda-server
             Section: utils
             Priority: optional
    The line we care about right now is the "Depends" line. We first need to install all of these packages, easiest way is to run apt-get for these.

    Code:
    #apt-get install ca-certificates
    Repeat for all the dependencies, some you may already have installed, but run through each one just to be sure.

    After all the dependencies are installed we can install Amanda:

    Code:
    # dpkg -i amanda-backup-server_3.3.3-1Ubuntu1204_amd64.deb
    Output might look like this:

    Code:
    Selecting previously unselected package amanda-backup-server.
    (Reading database ... 52396 files and directories currently installed.)
    Unpacking amanda-backup-server (from amanda-backup-server_3.3.3-1Ubuntu1204_amd64.deb) ...
    Setting up amanda-backup-server (3.3.3-1Ubuntu1204) ...
    Amanda installation log can be found in '/var/log/amanda/install.log'.
    Processing triggers for man-db ...
    You can review the logs located at /var/log/amanda/install.log for more information about the install process. From here you have to create/modify your configs based on what and how you'd like things backed up. I'm still learning that portion so I'm certainly not the person to ask about it.

  3. #3
    Join Date
    Apr 2013
    Posts
    2

    Default

    Thank you!

    I was able to get the application installed. Now on to the configuration phase.

    Best Regards!!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •