The test for glib_major_version in patch/build 3.3.3.svn.5188 appears to be backwards.

!glib_major_version < 2 always fails for glib 2.0+ (2.34 in my case)

I think this fixes it.

----------------------------------------------------------------------------------------------------------

Index: ./common-src/glib-util.c

--- ./common-src/glib-util.c 2013-03-18 09:54:09.000000000 -0400
+++ ./common-src/glib-util.c 2012-03-18 09:54:09.000000000 -0400
@@ -100,7 +100,7 @@
* is initialized) */
#ifdef HAVE_LIBCURL
# ifdef G_THREADS_ENABLED
- if (!glib_major_version < 2 ||
+ if (!glib_major_version > 2 ||
(glib_major_version == 2 && glib_minor_version < 31))
g_assert(!g_thread_supported()); /* assert threads aren't initialized yet */
# endif

----------------------------------------------------------------------------------------------------------