Results 1 to 2 of 2

Thread: mysql zrm incremental backup failed with mysql error unknown command '\0'

  1. #1
    Join Date
    Feb 2013
    Location
    bangalore India
    Posts
    3

    Post mysql zrm incremental backup failed with mysql error unknown command '\0'

    I am trying to restore an incremental backup of the MySQL database with blob data. I am using SUSE Linux. It is getting failed with MySQL error unknown command '\0'. Checked with increasing the size of max_allowed_packet_size to 1 GB in the my.cnf but still getting the same error.

    BackupSet1:restore:INFO: BINLOG = mysqlbinlog "/mysql-zrm/20130212170902"/mysql-bin.[0-9]* >> /tmp/VuPVfJAACd
    BackupSet1:restore:ERROR: Output of command: 'mysql -e "source /tmp/VuPVfJAACd;"' is {
    ERROR at line 202087 in file: '/tmp/VuPVfJAACd': Unknown command '\0'.
    }
    ERROR: Incremental restore failed
    BackupSet1:restore:ERROR: Incremental restore failed
    BackupSet1:restore:ERROR: Restore failed

    From other mysql restore forums I found that we can use --hex-blob while taking dump but not sure how to do it in zrm configuration.

    Any suggestions to restore is greatly appreciated and thanks in advance.

  2. #2
    Join Date
    Feb 2013
    Location
    bangalore India
    Posts
    3

    Default

    Currently we have changed backup type to logical where we have got the option --extra-mysqldump-options="--hex-blob --skip-extended-insert" and configured in the mysq-zrm.conf file. Testing this option which may help us for future errors, but still did not get any solution for restoring the backups taken before.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •