Results 1 to 5 of 5

Thread: amrecover error- can't talk to tape server: [request failed: amandahost: is not local

  1. #1
    Join Date
    Jan 2013
    Posts
    9

    Default amrecover error- can't talk to tape server: [request failed: amandahost: is not local

    Hello,

    I am running Amanda 3.1.3 on a Fedora 14 server. I have followed the instructions for Building a Basic Configuration. I am backing only the server to a hard disk attached to it using virtual tapes - no remote hosts. The amcheck report suggests the backup is created normally.

    Using amrecover, I can open the archive, navigate it and add files to be extracted - no problem. However, when I try to actually extract the files I get the following error:
    ---------------------------------------------------------------------------------
    # amrecover MyConfig
    AMRECOVER Version 3.1.3. Contacting server on localhost ...
    220 myserver1 AMANDA index server (3.1.3) ready.
    Setting restore date to today (2013-01-10)
    200 Working date set to 2013-01-10.
    200 Config set to MyConfig.
    200 Dump host set to myserver1.domain.com.
    Use the setdisk command to choose dump disk to recover

    amrecover> setdisk /etc
    200 Disk set to /etc.

    amrecover> add aliases
    Added file /aliases

    amrecover> list
    TAPE MyData02:2 LEVEL 0 DATE 2013-01-03-16-36-38
    /aliases

    amrecover> history
    200- Dump history for config "MyConfig" host "myserver1.domain.com" disk /etc
    201- 2013-01-03-16-36-38 0 MyData02:2
    200 Dump history for config "MyConfig" host "myserver1.domain.com" disk /etc

    amrecover> extract

    Extracting files using tape drive changer on host amandahost.
    The following tapes are needed: MyData02

    Extracting files using tape drive changer on host amandahost.
    Load tape MyData02 now
    Continue [?/Y/n/s/d]? y
    amrecover - can't talk to tape server: [request failed: amandahost: is not local]
    ---------------------------------------------------------------------------------

    I have tried to run both versions of amtape in a second window as suggested in the wiki section "How To:Restore from Virtual Tapes":
    ---------------------------------------------------------------------------------
    amtape woo slot 14 # option 1 OR
    amtape woo label B3_14 # option 2
    ---------------------------------------------------------------------------------

    I have also tried both approaches to setting up the amanda services in /etc/xinetd.d:
    [url]http://archives.zmanda.com/amanda-archives/viewtopic.php?t=6105&sid=6c7951963af9dd06850cef51b 69f91c8[/url]

    In all of my attempts to recover a file (e.g., aliases), I get the same error:
    ---------------------------------------------------------------------------------
    amrecover - can't talk to tape server: [request failed: amandahost: is not local]
    ---------------------------------------------------------------------------------

    Not sure if it will help, but I have installed the following Amanda packages:
    ------------------------------------------------------------------------------
    # yum list installed | grep amanda
    amanda.x86_64 3.1.3-3.fc14
    amanda-client.x86_64 3.1.3-3.fc14
    amanda-server.x86_64 3.1.3-3.fc14
    ------------------------------------------------------------------------------

    I am very new to Amanda and have tried all suggestions I could find but the issue still remains. Any advise would be greatly appreciated!
    Last edited by dkunev; January 10th, 2013 at 04:09 PM.

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,044

    Default

    Quote Originally Posted by dkunev View Post
    ---------------------------------------------------------------------------------
    amrecover - can't talk to tape server: [request failed: amandahost: is not local]
    ---------------------------------------------------------------------------------
    The 'local' auth can only be used to connect to 'localhost' or to the canonical name of the host.
    You can't use the 'local' auth to connect to amandahost
    Either use the 'local' auth to connect to localhost
    or use the 'bsdtcp' auth to connect to amandahost.

  3. #3
    Join Date
    Jan 2013
    Posts
    9

    Default

    martineau, thanks for the advise!

    I believe, you suggest I make the amanda-client config file to be:
    # cat /etc/amanda/amanda-client.conf
    index_server "amandahost"
    tapedev "changer"
    auth "bsdtcp"

    However, when I run amrecover, I get the following:
    # amrecover MyConfig
    AMRECOVER Version 3.1.3. Contacting server on amandahost ...
    [request failed: resolve_hostname(amandahost): Name or service not known

    My original amanda-client config is:
    # cat /etc/amanda/amanda-client.conf
    index_server "localhost"
    tapedev "changer"
    auth "local"

    Which, of course, results in the output/problem from my original post.

    I also tried using myserver1/myserver1.domain.com as arguments (one at a time) of index_server in amanda-client.conf. Each time I got the following:
    # cat /etc/amanda/amanda-client.conf
    index_server "myserver1/myserver1.domain.com"
    tapedev "changer"
    auth "bsdtcp"

    # amrecover MyConfig
    AMRECOVER Version 3.1.3. Contacting server on myserver1/myserver1.domain.com ...
    [request failed: Connection refused]

    Any further suggestions would be welcomed!

  4. #4
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,044

    Default

    I suggest you set the tape-server to the same value as the index-server:
    tape-server "localhost"

    If you use bsdtcp, then you must configure amandad in xinetd.

  5. #5
    Join Date
    Jan 2013
    Posts
    9

    Default Recovery successful!

    Quote Originally Posted by martineau View Post
    I suggest you set the tape-server to the same value as the index-server:
    tape-server "localhost"

    If you use bsdtcp, then you must configure amandad in xinetd.
    The tape-server setting did the trick!!!

    I also had to do the following for the extract to work:
    ...
    Load tape MyData02 now
    Continue [?/Y/n/d]? d
    New device name [?]: tpchanger
    ...

    Thanks, marteneau!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •