Results 1 to 2 of 2

Thread: Unable to use Tape: /dev/nst0: Input/output error

  1. #1

    Question Unable to use Tape: /dev/nst0: Input/output error

    Hi,
    I have configure amanda on HP Storage Works MSL2024.
    -bash-4.0$ mtx -f /dev/changer status
    Storage Changer /dev/changer:1 Drives, 24 Slots ( 1 Import/Export )
    Data Transfer Element 0:Full (Storage Element 20 Loaded)
    Storage Element 1:Full
    Storage Element 2:Full
    Storage Element 3:Full
    Storage Element 4:Full
    Storage Element 5:Full
    Storage Element 6:Full
    Storage Element 7:Full
    Storage Element 8:Full
    Storage Element 9:Full
    Storage Element 10:Full
    Storage Element 11:Empty
    Storage Element 12:Full
    Storage Element 13:Full
    Storage Element 14:Full
    Storage Element 15:Full
    Storage Element 16:Full
    Storage Element 17:Full
    Storage Element 18:Full
    Storage Element 19:Full
    Storage Element 20:Empty
    Storage Element 21:Full
    Storage Element 22:Full
    Storage Element 23:Full
    Storage Element 24 IMPORT/EXPORT:Full
    -bash-4.0$ mtx -f /dev/changer inquiry
    Product Type: Medium Changer
    Vendor ID: 'HP '
    Product ID: 'MSL G3 Series '
    Revision: '4.40'
    Attached Changer API: No

    My settings for DailySet1 are:
    tpchanger "chg-zd-mtx"
    tapedev "tape:/dev/nst0" # the no-rewind tape device to be used
    changerfile "/etc/amanda/DailySet1/changer.conf"
    changerdev "/dev/sg2"
    define tapetype HP-LTO4 {
    length 772096 mbytes
    filemark 0 kbytes
    speed 71093 kps
    }


    I have check by going through various post and documentation that these settings are correct. Using Hard Disk as storage, I am able to take backup without any problem.
    I am Unable to use Tape for backup as for every reading or writing I am getting error: /dev/nst0: Input/output error

    -bash-4.0$ amtape DailySet1 show
    amtape: scanning all 23 slots in tape-changer rack:
    Error reading 32768 bytes from /dev/nst0: Input/output error
    Error reading Amanda header.
    amtape: slot 5: Device error, Volume not labeled, or Volume error
    Error reading 32768 bytes from /dev/nst0: Input/output error
    Error reading Amanda header.
    amtape: slot 6: Device error, Volume not labeled, or Volume error
    Error reading 32768 bytes from /dev/nst0: Input/output error
    Error reading Amanda header.
    ........

    Please guide me.

  2. #2
    Join Date
    Jun 2013
    Posts
    11

    Default

    I got this same problem today with my PowerVault 124T Library. I just restarted the tape library and everything started working again. I doubt that's much help though .

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •