Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: How to exclude two files on one DLE wit amsamba?

  1. #1

    Default How to exclude two files on one DLE wit amsamba?

    Hi,
    Im trying to solve this issue now for quite a while, but so far I had no luck with it.
    So how do I exclude two files that a in different directories on one DLE?

  2. #2
    Join Date
    Aug 2012
    Posts
    81

    Default

    You have changed GUNTAR to APPLICATION with amsamba plugin, right? Can you confirm if it is working properly from your log?

  3. #3

    Default

    Hi,
    yes I changed that to amsamba. This is what it gives me as reply in the reports:

    sendbackup: info BACKUP=APPLICATION
    sendbackup: info APPLICATION=amsamba
    sendbackup: info RECOVER_CMD=/bin/gzip -dc |/usr/lib/amanda/application/amsamba restore [./file-to-restore]+
    sendbackup: info COMPRESS_SUFFIX=.gz
    sendbackup: info end

    So at least I think it should work.

  4. #4
    Join Date
    Aug 2012
    Posts
    81

    Default

    OK, I am going to set up a similar environment as yours, and see if it is a way to exclude files.

  5. #5
    Join Date
    Aug 2012
    Posts
    81

    Default

    I set up a similar environment as yours:
    Server: Debian 6 , Amanda Community-server 3.3.1
    Client: Windows 7, ZWC Community 3.3

    By adding following in "/etc/amanda/template.d/dumptypes", amdump can exclude the "1.zip".

    define dumptype zwc-normal {
    global
    program "APPLICATION"
    application {
    plugin "amsamba"
    }
    exclude "1.zip"
    }

    Make sure that the dumptype you are using (you can find it in /etc/amanda/your-set/disklist) is the one you define in dumptypes (or in amanda.conf).

    Good luck!

  6. #6

    Default

    Thanks for all the work you have made for me.
    Well I dont use any client software on the Windows machine. Do I need the ZWC?

    I still have some questions about the recover process. Usually I do it with the amrecover program and I had never any problems with it. But now somehow some directories are just empty.
    Even when I set the date to a level 0 run there are some directories which appear to be empty.


    Edit:
    Here you have my dump types:


    define dumptype root-samba {
    program "APPLICATION"
    application{
    plugin "amsamba"
    }
    comment "root partitions dumped with tar"
    compress client fast
    index yes
    priority medium
    estimate server
    auth "bsdtcp"
    }


    define dumptype root-exclude {
    program "APPLICATION"
    application{
    plugin "amsamba"
    }
    compress client best
    index yes
    exclude "System/SQ/90716.MDF"
    priority medium
    estimate client
    auth "bsdtcp"
    }
    Last edited by Alternativend; October 7th, 2012 at 11:48 PM.

  7. #7
    Join Date
    Aug 2012
    Posts
    81

    Default

    Quote Originally Posted by Alternativend View Post
    Hi there,
    im using Debian 6 with Amanda 2.6.1p2 (from Debian ) and the same version of the ZWC Windows Client in my Windows Server 2003 64Bit.
    The problem is that the ZWCService.exe seems to crash every 2 or 3 days or so. The process itself is still running but an amcheck gives out planner: ERROR Request to SERVER failed: timeout waiting for ACK. When I restart the service manually everything works fine again, at least for a few days.

    Is there anything I can do about it?

    Greetings
    This is you, right?
    From [url]https://forums.zmanda.com/showthread.php?4413[/url]

    I suggest you that make a simplest dumptype to test excluding files as I did.

    Make sure your file path is right.
    My 1.zip is at the top level of my backup folder:
    c:/backup/1.zip

  8. #8

    Default

    Hi there,
    excluding files in the top level does work. But I still have problems with excluding files from sub directories.
    I will keep you informed.

  9. #9

    Default

    So excluding from the top level directory does work, but nothing that goes deeper.

    exclude "spaeter.xls" <- does work

    exclude "/System/spaeter.xls" <- does not

    What Im doing wrong?

  10. #10
    Join Date
    Aug 2012
    Posts
    81

    Default

    For a Windows client, you need to use escape character (\) before the backslash (\).
    exclude "sub\\1.zip"

    You can find more info at here [url]http://wiki.zmanda.com/man/amanda.conf.5.html[/url]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •