I currently have Amanda 3.3.0 installed on Ubuntu 12.04.1 (LTS). Since March 31 of this year, Amanda had been failing with g_thread_supported error. This afternoon, I ran amstatus just to see if the g_thread_supported error had been repaired:

$ sudo -u backup amstatus elijah

** (process:15730): WARNING **: Legacy library newgetopt.pl will be removed from the Perl core distribution in the next major release. Please install the separate libperl4-corelibs-perl package. It is being used at /usr/sbin/amstatus, line 9.

Using /var/backups/amanda/state/log/amdump.1
From Thu Jul 26 13:57:06 CDT 2012
...


Are the Amanda developers replacing the newgetopt.pl library in an upcoming release?

Thanks!