Results 1 to 3 of 3

Thread: currently loaded slot () not numeric

  1. #1
    Join Date
    Sep 2012
    Posts
    1

    Default currently loaded slot () not numeric

    Hello,

    I'm using Amanda 3.1.5 on CentOS 6.3 with a 24 slot library. When I go to label the tapes in the library I get the following error:

    Code:
    No source specified
    Reading label...
    currently loaded slot () not numeric
    Do not know which slot to unload tape into!
    Drive 0 Full (Storage Element 0 loaded)
    amcheck shows everything is okay I just can't seem to label the tapes properly. What am I doing wrong?

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,019

    Default

    amanda can't parse the mtx output.
    Which version of mtx are you using?
    What is output of: mtx -f /dev/.... status

  3. #3
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    306

    Default

    Code:
    currently loaded slot () not numeric
    Do not know which slot to unload tape into!
    Drive 0 Full (Storage Element 0 loaded)
    This generally means there is a tape in the drive and also in all slots such that there is no empty slot for Amanda to unload the tape in the drive to. As Amanda leaves the tape last used in the tape drive, this can occur if you unload all tapes in the changer and then fill in new tapes into every slot. The changer is then unable to unload the drive until at least one slot is freed up. This will cause the "loaded slot is not numeric" message because the drive will not report the currently loaded tape to be from any of the numbered slots when they are each already filled with a tape.

    Remembering to eject the tape in the drive before unloading/loading tapes into the changer usually avoids this. You can use amtape's "eject" command to perform this.

    Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •