Results 1 to 3 of 3

Thread: Always Level 0 backup, why not L1?

  1. #1
    Join Date
    Jun 2012
    Location
    Arendal, Norway
    Posts
    4

    Default Always Level 0 backup, why not L1?

    Hi,

    I have a setup where I take both local and remote backup (via SSH). Works great, but it always takes a level 0 backup from the remote host, and that takes about 17-24 hours. And I do not understand why Amanda never takes a level 1 backup instead? I know there is some built-in mechanics, but the documents says the network-speed is a factor...

    Is there any way I can adjust it so the level 0 backups is not happening every day?

    Here are my config:
    Code:
    org "MyConfig"
    infofile "/opt/amanda/state/curinfo"
    logdir "/opt/amanda/state/log"
    indexdir "/opt/amanda/state/index"
    
    tpchanger "chg-disk:/media/wd15tb/amanda/vtapes"
    labelstr "MyData[0-9][0-9]"
    autolabel "MyData%%" EMPTY VOLUME_ERROR
    tapecycle 20
    dumpcycle 8 days
    amrecover_changer "changer"
    dumpuser "amandabackup"
    
    mailto "root@<hidden>"
    
    tapetype "HARD-DISK"
    define tapetype HARD-DISK {
      length 204800 mbytes
      filemark 4 kbytes
    }
    
    define dumptype simple-gnutar-local {
        auth "local"
        compress none
        program "GNUTAR"
    }
    
    define dumptype comp-ssh {
      auth "ssh"
      ssh_keys "/etc/amanda/MyConfig/ssh-key"
      compress client best
      program "GNUTAR"
    }
    
    holdingdisk hd1 {
        directory "/opt/amanda/holding"
        use 20480 mbytes
        chunksize 1 mbyte
    }
    disklist:
    Code:
    localhost /etc                          simple-gnutar-local
    localhost /root                         simple-gnutar-local
    localhost /home                         simple-gnutar-local
    localhost /var/log                      simple-gnutar-local
    localhost /usr/local/sbin               simple-gnutar-local
    localhost /usr/local/bin                simple-gnutar-local
    localhost /opt/exports/nfs/home         simple-gnutar-local
    localhost /opt/exports/nfs/public/Music simple-gnutar-local
    hidden.org  /etc                    comp-ssh
    hidden.org  /root                   comp-ssh
    hidden.org  /var/log                comp-ssh
    hidden.org  /usr/local/sbin         comp-ssh
    hidden.org  /usr/local/bin          comp-ssh
    hidden.org  /home/erling/Maildir    comp-ssh
    hidden.org  /home/hanne/Maildir     comp-ssh
    hidden.org  /home/helge/Maildir     comp-ssh
    hidden.org  /home/jan/Maildir       comp-ssh
    hidden.org  /home/kristin/Maildir   comp-ssh
    hidden.org  /home/liv/Maildir       comp-ssh
    hidden.org  /home/mkrakvik/Maildir  comp-ssh
    hidden.org  /home/morthen/Maildir   comp-ssh
    hidden.org  /home/ragnhild/Maildir  comp-ssh
    hidden.org  /home/sitron/Maildir    comp-ssh
    hidden.org  /home/steivor/Maildir   comp-ssh
    hidden.org  /home/stv/Maildir       comp-ssh
    hidden.org  /home/sven/Maildir      comp-ssh
    hidden.org  /home/synnove/Maildir   comp-ssh
    See attached logfiles, I hope there is a clue somewhere... And yeah, hidden.org is not my real hostname :-)

    I appreciate any help or hints.
    Attached Files Attached Files

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Amanda try to balance the size of FULL every days, You get this problem when you have a few big dle and many smaller one, set the 'maxpromotedays' to a small value to prevent promototion to full.

    Do you noticed:
    planner: Last full dump of localhost:/opt/exports/nfs/home on tape MyData14 overwritten in 4 runs.
    planner: disk localhost:/opt/exports/nfs/home, full dump (305922920KB) will be larger than available tape space

    You must enable splitting or the latest full be overwritten and you will never get a new full backup.

  3. #3
    Join Date
    Jun 2012
    Location
    Arendal, Norway
    Posts
    4

    Default

    Thanks for the heads up about the full dump that where too big. Since I use virtual tapes on a external HDD, I just increased the tapesize.

    I have also set maxpromotedays to 3 for dumptype comp-ssh, so now I just wait and see what Amanda does for the next week.

    Anyway, thanks for the reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •