Results 1 to 4 of 4

Thread: Need help: Unable to restore; amrestore hangs

  1. #1
    Join Date
    Feb 2012
    Location
    Michigan
    Posts
    3

    Default Need help: Unable to restore; amrestore hangs

    I am trying to set up an Amanda backup server on CentOS 6.2. The Amanda version is Amanda-2.6.1p2.

    I got it to the point where I can back up to virtual tapes. However, when I try to restore, amrestore seems to hang.

    I am using NFS mounts to backup my remote servers; I can't use the client for reasons I don't want to go into. I have both the Amanda server and the Amanda client installed on the CentOS server.

    This is what I see when I try to restore:

    Code:
    [root@murphy amanda]# amrecover
    AMRECOVER Version 2.6.1p2. Contacting server on murphy.tcslab.ford.com ...
    220 murphy AMANDA index server (2.6.1p2) ready.
    Setting restore date to today (2012-02-02)
    200 Working date set to 2012-02-02.
    200 Config set to QIPSrvrs.
    200 Dump host set to murphy.tcslab.ford.com.
    Use the setdisk command to choose dump disk to recover
    amrecover> listdisk
    200- List of disk for host murphy.tcslab.ford.com
    201- /data/nfs/qiplab-e01/etc
    201- /data/nfs/qiplab-e01/usr/local/etc
    201- /data/nfs/qiplab-e01/apps/qip
    201- /data/nfs/qiplab-e01/misc/etc
    201- /data/nfs/qiplab-e01/misc/scripts/labsetup
    200 List of disk for host murphy.tcslab.ford.com
    amrecover> setdisk /data/nfs/qiplab-e01/usr/local/etc
    200 Disk set to /data/nfs/qiplab-e01/usr/local/etc.
    amrecover> ls
    2012-02-02-14-13-56 wgetrc
    2012-02-02-14-13-56 sudoers.original
    2012-02-02-14-13-56 sudoers
    2012-02-02-14-13-56 openldap/
    2012-02-02-14-13-56 .amanda.exclude
    2012-02-02-14-13-56 .
    amrecover> add sudoers.original
    Added file /sudoers.original
    amrecover> extract
    
    Extracting files using tape drive qiptape on host murphy.tcslab.ford.com.
    The following tapes are needed: QIPSrvr-3
    
    Restoring files into directory /data/recover/amanda
    Continue [?/Y/n]? Y
    
    Extracting files using tape drive qiptape on host murphy.tcslab.ford.com.
    Load tape QIPSrvr-3 now
    Continue [?/Y/n/s/d]? Y
    At this point, the prompt sits there until I kill it.

    This is my amanda.conf:

    Code:
    org "QIP Servers Backup"
    mailto "amandabackup"
    dumpcycle 7
    runspercycle 5
    tapecycle 40
    dumpuser "amandabackup"
    tpchanger "chg-disk:/data/backup/amanda/vtapes/qipsrvrs/slots"
    labelstr "QIPSrvr-.*"
    label-new-tapes "QIPSrvr-%%"
    tapetype DVD47
    logdir "/var/lib/amanda/QIPSrvrs"
    infofile "/var/lib/amanda/QIPSrvrs/curinfo"
    indexdir "/var/lib/amanda/QIPSrvrs/index"
    tapelist "/var/lib/amanda/QIPSrvrs/tapelist"
    
    #holdingdisk hd1 {
    #   directory "/data/backup/amanda/holdingdisk/QIPSrvrs"
    #}
    
    define dumptype comp-tar {
       program "GNUTAR"
       compress server fast
       index yes
       record yes
       exclude list ".amanda.exclude"
       auth "bsdtcp"
    }
    
    define tapetype DVD47 {
       comment "A 4.7 Gbyte DVD-sized vtape"
       filemark 4 KB
       length 4482 MB
    }
    
    define changer qiptape {
       tpchanger "chg-disk:/data/backup/amanda/vtapes/qipsrvrs/slots"
    }
    
    amrecover_changer "qiptape"
    
    ### END CONFIGURATION
    And this is my amanda-client.conf:

    Code:
    conf "QIPSrvrs"         # your config name
    
    index_server "murphy.tcslab.ford.com"   # your amindexd server
    tape_server  "murphy.tcslab.ford.com"   # your amidxtaped server
                            # if not set, Use configure or ask server.
                            # if set to empty string "", ask server
                            # amrecover will use the changer if set to the value
                            # of 'amrecover_changer' in the server amanda.conf.
    tapedev ""
    
    auth "bsdtcp"
    
    unreserved-tcp-port 1025,65535
    
    ### END CONFIGURATION
    .amandahosts file:

    Code:
    murphy root amindexd amidxtaped
    murphy amandabackup amdump
    murphy.tcslab.ford.com amandabackup amdump
    murphy.tcslab.ford.com root amindexd amidxtaped
    And finally, /etc/xinetd.d/amanda:

    Code:
    service amanda
    {
            disable = no
            socket_type             = stream
            protocol                = tcp
            wait                    = no
            user                    = amandabackup
            group                   = disk
            groups                  = yes
            server                  = /usr/lib64/amanda/amandad
            server_args             = -auth=bsdtcp amdump amindexd amidxtaped
    }
    
    ### END CONFIGURATION
    Can anyone tell me what I am doing wrong, or give me any suggestions to figure out why this isn't working?

  2. #2
    Join Date
    Feb 2012
    Location
    Michigan
    Posts
    3

    Default

    PS. I should also mention that I have opened up a separate terminal session and verified with amtape that the virtual tape was loaded. It doesn't seem to make any difference.

  3. #3
    Join Date
    Aug 2008
    Posts
    184

    Default

    Hopefully someone will chime in with some tips. But note that you are using a *very* old version of Amanda. Would recommend looking into a recent version:

    [url]http://www.zmanda.com/download-amanda.php[/url]

  4. #4
    Join Date
    Feb 2012
    Location
    Michigan
    Posts
    3

    Default

    Quote Originally Posted by zbackup View Post
    Hopefully someone will chime in with some tips. But note that you are using a *very* old version of Amanda. Would recommend looking into a recent version:

    [url]http://www.zmanda.com/download-amanda.php[/url]
    Believe me, I thought about it. But this system is in an isolated lab environment and I don't have direct internet access, so I'm concerned about "dependency hell". CentOS may not have been a good choice in hindsight, but I knew it would run on this server.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •