Results 1 to 2 of 2

Thread: Getting my config for spanning tapes correct

  1. #1

    Default Getting my config for spanning tapes correct

    I am not seeing any files created in either the holding or span folders that I have defined in my amanda.conf.

    I can see the holding folder created for each run while it is running but I never see any files in it.

    Seems to be running everything in memory.

    Code:
    runtapes 3  
    
    define changer myrobot {
      tapedev "chg-robot:/dev/sg2"  # your changer device file
      property "tape-device" "0=tape:/dev/nst0"     # your tape drive device file
      property "use-slots" "1-7"
    }
    tapedev "myrobot"
    
    
    maxdumpsize -1          # Maximum number of bytes the planner will schedule
                                   # for a run (default: runtapes * tape_length).
    tapetype LTO2-200     # what kind of tape it is (see tapetypes below)
    
    holdingdisk hd1 {
        comment "main holding disk"
        directory "/home/amanda/dumps"      # where the holding disk is
        use -100 Mb                 # how much space can we use on it
        chunksize 10Gb      # size of chunk if you want big dump to be
        }
    
    define tapetype LTO2-200 {
         comment "LTO Ultrium2 200/400"
         length 193024 mbytes
         filemark 0 kbytes
         speed 20570 kps
             part_size 19302 mbytes # use about 1/10 of your tape size
         part_cache_type disk
         part_cache_dir "/home/amanda/span"
    }
    My dumps are taking much longer than they used to as well.
    Is there a conflict between the settings for the holding directory and span directory or settings.

    I might have figured out part of the timing, there is a gap of approx 7hrs between these to lines in the log.
    Not sure what is going on at this point in the process.

    Code:
    Tue Jan 10 23:04:47 2012: taper: Building type SPLIT_FILE header of 32768-32768 bytes with name='somehost' disk='/opt/CommuniGate' dumplevel=0 and blocksize=32768
    Wed Jan 11 06:31:10 2012: taper: Amanda::Taper::Scribe preparing to write, part size 20239613952, using cache type 'disk' (cacher)  (no LEOM)
    Last edited by powertoaster; January 11th, 2012 at 03:44 PM. Reason: Sanitize

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Part cache should be required only for older tape drive.
    You should set the device-property "LEOM" to "YES"

    Post the complete amdump.1 log file and the complete taper debug file.

    Much longer than what? Did you change something?

    Jean-Louis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •