Hi folks,

I am currently running amanda 2.61p2 on my backup server which runs Debian 6.0.3 and a number of other hosts. Seems all but one of my hosts which happens to be a CentOS 6.0 host work just fine. The CentOS host has consistently failed every morning when the backups run.

I have another CentOS host that is being backed up successfully every morning but that OS is CentOS 5.1. Not sure that is significant but I am not ruling it out at this point.

Looking in /var/log/amanda/client/daily I cat'ed out one of my sendbackup logs and saw something that I'm not sure why I'm seeing it:

1323421824.127996: sendbackup: pid 19747 ruid 33 euid 33 version 2.6.1p2: start at Fri Dec 9 04:10:24 2011
1323421824.128101: sendbackup: Version 2.6.1p2
1323421824.128817: sendbackup: pid 19747 ruid 33 euid 33 version 2.6.1p2: rename at Fri Dec 9 04:10:24 2011
1323421824.129462: sendbackup: Parsed request as: program `GNUTAR'
1323421824.129481: sendbackup: disk `/usr'
1323421824.129494: sendbackup: device `/usr'
1323421824.129506: sendbackup: level 0
1323421824.129518: sendbackup: since NODATE
1323421824.129530: sendbackup: options `'
1323421824.129695: sendbackup: start: chichost0.chi.sharkrivertech.com:/usr lev 0
1323421824.129755: sendbackup: pipespawnv: stdoutfd is 50
1323421824.129805: sendbackup: Spawning "/usr/bin/gzip /usr/bin/gzip --fast" in pipeline
1323421824.131033: sendbackup: gnutar: pid 19754: /usr/bin/gzip1323421824.131101: sendbackup: pid 19754: /usr/bin/gzip --fast
1323421824.131288: sendbackup: doing level 0 dump as listed-incremental to '/var/lib/amanda/gnutar-lists/chichost0.chi.sharkrivertech.com_usr_0.new'
1323421824.133613: sendbackup: pipespawnv: stdoutfd is 6
1323421824.133752: sendbackup: Spawning "/usr/lib64/amanda/runtar runtar daily /bin/tar --create --file - --directory /usr --one-file-system --listed-incremental /var/lib/amanda/gnutar-lists/chichost0.chi.sharkrivertech.com_usr_0.new --sparse --xattrs --ignore-failed-read --totals ." in pipeline
1323421824.134531: sendbackup: gnutar: /usr/lib64/amanda/runtar: pid 19757
1323421824.134601: sendbackup: Started backup
1323421824.141509: sendbackup: Started index creator: "/bin/tar -tf - 2>/dev/null | sed -e 's/^\.//'"
1323421954.507040: sendbackup: critical (fatal): index tee cannot write [Broken pipe]
/usr/lib64/libamanda-2.6.1p2.so(+0x21aa9)[0x7fc4e945caa9]
/lib64/libglib-2.0.so.0(g_logv+0x1b9)[0x7fc4e86bffd9]
/lib64/libglib-2.0.so.0(g_log+0x83)[0x7fc4e86c03f3]
/usr/lib64/amanda/sendbackup(start_index+0x28a)[0x7fc4e9d0c0ca]
/usr/lib64/amanda/sendbackup(+0x818a)[0x7fc4e9d0d18a]
/usr/lib64/amanda/sendbackup(main+0x1258)[0x7fc4e9d0ae28]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x7fc4e6b9ac5d]
/usr/lib64/amanda/sendbackup(+0x38c9)[0x7fc4e9d088c9]

What's up with that broken pipe? Anybody else experience this and better yet come up with a cure?