Results 1 to 3 of 3

Thread: ZRM remote backup to MySQL Slave server

  1. #1
    Join Date
    Oct 2011

    Exclamation ZRM remote backup to MySQL Slave server


    we are testing in our company these fantastic backup solution. I'm currently working with some MySQL 5.X master servers without problems. If these test run ok will think about comercial version.

    But, we have some MySQL slave server. And with this guy, we have very little issue.

    We are doing the copys using ssh-copy plugin. As we did with the others boys, we did the setup (ssh users) to one ssh user "zrm" can log in from ZRM backup host to MySQL server Host with no password.

    And it works! We can log in from MySQL ZRM Backup to MySQL SLave, but when I run

    # mysql-zrm-scheduler --backup-set slave_daily --backup-level 0 --now

    I get

    slave_daily:backup:INFO: START OF BACKUP
    slave_daily:backup:INFO: PHASE START: Initialization
    slave_daily:backup:INFO: The quick backup-type is supported only for sanpshot backups. Setting backup-type to 'regular'
    slave_daily:backup:INFO: backup-set=slave_daily
    slave_daily:backup:INFO: backup-date=20111019131405
    slave_daily:backup:INFO: mysql-server-os=Linux/Unix
    slave_daily:backup:INFO: backup-type=regular
    slave_daily:backup:INFO: host=
    slave_daily:backup:INFO: backup-date-epoch=1319022845
    slave_daily:backup:INFO: retention-policy=7D
    slave_daily:backup:INFO: mysql-zrm-version=ZRM for MySQL Community Edition - version 2.2.0
    slave_daily:backup:INFO: mysql-version=5.0.77-log
    slave_daily:backup:INFO: backup-directory=/var/lib/mysql-zrm/mj_slave_daily/20111019131405
    slave_daily:backup:INFO: backup-level=0
    slave_daily:backup:INFO: backup-mode=logical
    slave_daily:backup:INFO: PHASE END: Initialization
    slave_daily:backup:INFO: PHASE START: Running pre backup plugin
    slave_daily:backup:INFO: PHASE END: Running pre backup plugin
    slave_daily:backup:INFO: PHASE START: Stopping slave
    slave_daily:backup:INFO: PHASE END: Stopping slave
    slave_daily:backup:INFO: PHASE START: Flushing logs
    slave_daily:backup:INFO: PHASE END: Flushing logs
    slave_daily:backup:INFO: PHASE START: Copying replication data
    zrm@'s password:
    tar: Cannot open: Permission denied
    tar: Error exit delayed from previous errors
    Our config file for these backup set is the same to Master servers with only this change

    # This parameter should be set to 1 if MySQL ZRM backups are being on done on a
    # MySQL replication slave.
    Maybe we have done some error in setup by I swear ssh method is the same, as well the setup and I can log in by ssh with no problem :s

    If anybody has some idea will be helpful


  2. #2


    I'm assuming that you are running as mysql user. Does mysql user have permission to read the file?
    [URL=]Amanda backup and recovery [/URL]
    [URL=]MySQL backup and recovery[/URL]

  3. #3
    Join Date
    Oct 2011


    Quote Originally Posted by paddy View Post
    I'm assuming that you are running as mysql user. Does mysql user have permission to read the file?
    Hi Paddy

    when I run

    root@backup-host # mysql-zrm-scheduler --backup-set slave_daily --backup-level 0 --now

    I am executing the backup process from backup-host to msql remote slave server and I execute command as root from shell.

    In remote slave I have created a mysql user with privileges(on all databases), needed to connect from backup-host.

    And Im doing this with ssh-plugin enabled. SSH-User is able to connect from backup-host to remote-slave-server, tested, without password (I have setup ssh trust between both servers)

    With my rest of master databases, I have not any issue. What do you think about this config? Maybe is a problem of ssh user privilegeS?

    Thanks a lot dude

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts