Hi all,

I am using the fedora 13 version of Amanda-2.6.1p2. I have a Quantum internal SDLT320 as the tape device installed on a computer which is consistently bailing near the end of backing up a 110GB partition. I have tried breaking the spooled files up into 1Gb and 2Gb chunks (the partition gets compressed down to 40Gb after chunking). This system worked fine for years but has been failing for the last dozen backups when running the taper to move the chunks onto the tape.

From the taper log:

1311701220.585065: taper: is_partial = 0
1311701220.585084: taper: partnum = 19
1311701220.585103: taper: totalparts = 21
1311701220.585121: taper: blocksize = 32768
1311701369.775263: taper: putresult: 20 PARTDONE
1311701369.775623: taper: Building type 5 (SPLIT_FILE) header of size 32768 using:
1311701369.775654: taper: Contents of *(dumpfile_t *)0x1695f10:
1311701369.775675: taper: type = 5 (SPLIT_FILE)
1311701369.775695: taper: datestamp = '20110720111435'
1311701369.775714: taper: dumplevel = 0
1311701369.775734: taper: compressed = -32
1311701369.775753: taper: encrypted = 0
1311701369.775772: taper: comp_suffix = '.gz'
1311701369.775791: taper: encrypt_suffix = ''
1311701369.775809: taper: name = 'xxx.xxx.xxx'
1311701369.775852: taper: disk = '/home'
1311701369.775872: taper: program = '/bin/tar'
1311701369.775891: taper: application = ''
1311701369.775909: taper: srvcompprog = ''
1311701369.775928: taper: clntcompprog = ''
1311701369.775946: taper: srv_encrypt = ''
1311701369.775965: taper: clnt_encrypt = ''
1311701369.775984: taper: recover_cmd = '/bin/tar -xpGf - ...'
1311701369.776003: taper: uncompress_cmd = '/usr/bin/gzip -dc |'
1311701369.776022: taper: encrypt_cmd = ''
1311701369.776040: taper: decrypt_cmd = ''
1311701369.776059: taper: srv_decrypt_opt = ''
1311701369.776077: taper: clnt_decrypt_opt = ''
1311701369.776136: taper: cont_filename = ''
1311701369.776155: taper: dle_str = <dle>
<program>GNUTAR</program>
<disk>/home</disk>
<level>0</level>
<auth>BSD</auth>
<compress>FAST</compress>
<record>YES</record>
<index>YES</index>
<exclude>
<list>/var/lib/amanda/gnutar-lists/homeexclude.gtar</list>
</exclude>
</dle>
1311701369.776177: taper: is_partial = 0
1311701369.776196: taper: partnum = 20
1311701369.776215: taper: totalparts = 21
1311701369.776234: taper: blocksize = 32768
1311701517.047153: taper: warning: Got EIO on /dev/nst0, assuming end of tape
1311701517.052032: taper: Device /dev/nst0 error = 'No space left on device'
1311701517.053028: taper: Device /dev/nst0 setting status flag(s): DEVICE_STATUS_VOLUME_ERROR
1311701517.071611: taper: Device /dev/nst0 error = 'Error writing filemark: Input/output error'
1311701517.071698: taper: Device /dev/nst0 setting status flag(s): DEVICE_STATUS_DEVICE_ERROR, and DEVICE_STATUS_VOLUME_ERROR
1311701517.084809: taper: device /dev/nst0 ran out of space
1311701517.087184: taper: Device /dev/nst0 setting status flag(s): DEVICE_STATUS_DEVICE_ERROR, and DEVICE_STATUS_VOLUME_ERROR
1311701517.089352: taper: Device /dev/nst0 setting status flag(s): DEVICE_STATUS_DEVICE_ERROR, and DEVICE_STATUS_VOLUME_ERROR
1311701517.089984: taper: putresult: 26 REQUEST-NEW-TAPE
1311701517.093816: taper: Device /dev/nst0 error = 'Can't open tape device /dev/nst0: Input/output error'
1311701517.093886: taper: Device /dev/nst0 setting status flag(s): DEVICE_STATUS_DEVICE_ERROR
1311701517.105031: taper: getcmd: NO-NEW-TAPE "runtapes volumes already written"
1311701517.105144: taper: putresult: 4 PARTIAL
1311701517.105792: taper: getcmd: QUIT
1311701517.105855: taper: putresult: 2 QUITTING

According to the flush report for the above flush (after failed dump), the tape is not full (only 30%). The flush was 40Gb to a SDLT.

When the taper dies (or maybe this causes it to die), the tape unloads and the drive gets in a state where it will not load another tape unless I reboot; it just spits it right back out.

Does anyone have any ideas on how to fix this problem? I'm hoping that this isn't a hardware defect.

Oh yeah, the drive is controlled by an Adaptec ASC-29320ALP U320 card.

Thanks!