Hello zmanda forum

I am trying to re-create some virtual tapes after the hard disk that they were living on crashed. This is in a test lab, so not as high a priority as production. But still important as this is where dry runs occur before they go there.

Here is my situation. I empty my config's tapelist with cat /dev/null > $config/tapelist. I then delete the virtual tapes on the disk and recreate them. But when I go to label the newly recreated tapes with amlabel I get an error claiming

Code:
Volume with label 'SNJH-1' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-1' from the catalog.
I get this for all tapes in the set:

Code:
-sh-3.2$ for i in {1..15}; do /usr/sbin/amlabel -f SNJH SNJH-${i} slot ${i}; done
Reading label...
Found an empty tape.
Writing label 'SNJH-1'...
Checking label...
Success!
Reading label...
Volume with label 'SNJH-1' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-1' from the catalog.
Writing label 'SNJH-2'...
Checking label...
Success!
Reading label...
Volume with label 'SNJH-2' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-2' from the catalog.
Writing label 'SNJH-3'...
Checking label...
Success!
Reading label...
Volume with label 'SNJH-3' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-3' from the catalog.
Writing label 'SNJH-4'...
Checking label...
Success!
Reading label...
Volume with label 'SNJH-4' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-4' from the catalog.
Writing label 'SNJH-5'...
Checking label...
Success!
Reading label...
Volume with label 'SNJH-5' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-5' from the catalog.
Writing label 'SNJH-6'...
Checking label...
Success!
Reading label...
Volume with label 'SNJH-6' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-6' from the catalog.
Writing label 'SNJH-7'...
Checking label...
Success!
Reading label...
Volume with label 'SNJH-7' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-7' from the catalog.
Writing label 'SNJH-8'...
Checking label...
Success!
Reading label...
Volume with label 'SNJH-8' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-8' from the catalog.
Writing label 'SNJH-9'...
Checking label...
Success!
Reading label...
Volume with label 'SNJH-9' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-9' from the catalog.
Writing label 'SNJH-10'...
Checking label...
Success!
Reading label...
Volume with label 'SNJH-10' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-10' from the catalog.
Writing label 'SNJH-11'...
Checking label...
Success!
Reading label...
Volume with label 'SNJH-11' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-11' from the catalog.
Writing label 'SNJH-12'...
Checking label...
Success!
Reading label...
Volume with label 'SNJH-12' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-12' from the catalog.
Writing label 'SNJH-13'...
Checking label...
Success!
Reading label...
Volume with label 'SNJH-13' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-13' from the catalog.
Writing label 'SNJH-14'...
Checking label...
Success!
Reading label...
Volume with label 'SNJH-14' is active and contains data from this configuration.
Consider using 'amrmtape' to remove volume 'SNJH-14' from the catalog.
Writing label 'SNJH-15'...
Checking label...
Success!
But when I run amtape show, I see only one tape.. SNJH-15

Code:
-sh-3.2$ amtape SNJH show
amtape: scanning all 1 slots in changer:
slot   1: date X              label SNJH-15
This is what my tapelist curently shows after the above labeling process:

Code:
-sh-3.2$ cat /etc/amanda/SNJH/tapelist
0 SNJH-15 reuse
0 SNJH-14 reuse
0 SNJH-13 reuse
0 SNJH-12 reuse
0 SNJH-11 reuse
0 SNJH-10 reuse
0 SNJH-9 reuse
0 SNJH-8 reuse
0 SNJH-7 reuse
0 SNJH-6 reuse
0 SNJH-5 reuse
0 SNJH-4 reuse
0 SNJH-3 reuse
0 SNJH-2 reuse
0 SNJH-1 reuse
I try to amrmtape all the tapes as suggested by the error message from above:
Code:
-sh-3.2$ for i in {1..15}; do amrmtape SNJH SNJH-$i; done
label 'SNJH-15' not found in /etc/amanda/SNJH/tapelist
And I get an error telling me that the one tape that is listed in amtape $config show is not in the tapelist.

If I try to use the tape list as it is, I get broken pipe errors. I feel that I must resolve this tape creation issue before I can get functioning tapes.

Code:
  /-- VIRTCENT13.summitnjhome.com /etc lev 0 FAILED [data write: Broken pipe]
  sendbackup: start [VIRTCENT13.summitnjhome.com:/etc level 0]
  sendbackup: info BACKUP=/bin/tar
  sendbackup: info RECOVER_CMD=/bin/gzip -dc |/bin/tar -xpGf - ...
  sendbackup: info COMPRESS_SUFFIX=.gz
  sendbackup: info end
  ? encrypt: which: no aespipe in (/usr/sbin:/usr/libexec/amanda:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/sbin:/usr/sbin:/sbin:/usr/ucb:/opt/csw/bin)
  ? encrypt: /usr/sbin/amcrypt: aespipe was not found in /usr/sbin:/usr/libexec/amanda:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/sbin:/usr/sbin:/sbin:/usr/ucb:/opt/csw/bin
  \--------
  /-- VIRTCENT13.summitnjhome.com /etc lev 0 FAILED [data write: Broken pipe]
  sendbackup: start [VIRTCENT13.summitnjhome.com:/etc level 0]
  sendbackup: info BACKUP=/bin/tar
  sendbackup: info RECOVER_CMD=/bin/gzip -dc |/bin/tar -xpGf - ...
  sendbackup: info COMPRESS_SUFFIX=.gz
  sendbackup: info end
  ? encrypt: which: no aespipe in (/usr/sbin:/usr/libexec/amanda:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/sbin:/usr/sbin:/sbin:/usr/ucb:/opt/csw/bin)
  ? encrypt: /usr/sbin/amcrypt: aespipe was not found in /usr/sbin:/usr/libexec/amanda:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/sbin:/usr/sbin:/sbin:/usr/ucb:/opt/csw/bin
  \--------
  /-- VIRTCENT13.summitnjhome.com /var lev 1 FAILED [data write: Broken pipe]
  sendbackup: start [VIRTCENT13.summitnjhome.com:/var level 1]
  sendbackup: info BACKUP=/bin/tar
  sendbackup: info RECOVER_CMD=/bin/gzip -dc |/bin/tar -xpGf - ...
  sendbackup: info COMPRESS_SUFFIX=.gz
  sendbackup: info end
  ? encrypt: which: no aespipe in (/usr/sbin:/usr/libexec/amanda:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/sbin:/usr/sbin:/sbin:/usr/ucb:/opt/csw/bin)
  ? encrypt: /usr/sbin/amcrypt: aespipe was not found in /usr/sbin:/usr/libexec/amanda:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/sbin:/usr/sbin:/sbin:/usr/ucb:/opt/csw/bin
  \--------
  /-- VIRTCENT13.summitnjhome.com /var lev 1 FAILED [data write: Broken pipe]
  sendbackup: start [VIRTCENT13.summitnjhome.com:/var level 1]
  sendbackup: info BACKUP=/bin/tar
  sendbackup: info RECOVER_CMD=/bin/gzip -dc |/bin/tar -xpGf - ...
  sendbackup: info COMPRESS_SUFFIX=.gz
  sendbackup: info end
  ? encrypt: which: no aespipe in (/usr/sbin:/usr/libexec/amanda:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/sbin:/usr/sbin:/sbin:/usr/ucb:/opt/csw/bin)
  ? encrypt: /usr/sbin/amcrypt: aespipe was not found in /usr/sbin:/usr/libexec/amanda:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/sbin:/usr/sbin:/sbin:/usr/ucb:/opt/csw/bin
  \--------
  /-- VIRTCENT13.summitnjhome.com /root lev 0 FAILED [data write: Broken pipe]
  sendbackup: start [VIRTCENT13.summitnjhome.com:/root level 0]
  sendbackup: info BACKUP=/bin/tar
  sendbackup: info RECOVER_CMD=/bin/gzip -dc |/bin/tar -xpGf - ...
  sendbackup: info COMPRESS_SUFFIX=.gz
  sendbackup: info end
  ? encrypt: which: no aespipe in (/usr/sbin:/usr/libexec/amanda:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/sbin:/usr/sbin:/sbin:/usr/ucb:/opt/csw/bin)
  ? encrypt: /usr/sbin/amcrypt: aespipe was not found in /usr/sbin:/usr/libexec/amanda:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/sbin:/usr/sbin:/sbin:/usr/ucb:/opt/csw/bin
  \--------
  /-- VIRTCENT13.summitnjhome.com /root lev 0 FAILED [data write: Broken pipe]
  sendbackup: start [VIRTCENT13.summitnjhome.com:/root level 0]
  sendbackup: info BACKUP=/bin/tar
  sendbackup: info RECOVER_CMD=/bin/gzip -dc |/bin/tar -xpGf - ...
  sendbackup: info COMPRESS_SUFFIX=.gz
  sendbackup: info end
  ? encrypt: which: no aespipe in (/usr/sbin:/usr/libexec/amanda:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/sbin:/usr/sbin:/sbin:/usr/ucb:/opt/csw/bin)
  ? encrypt: /usr/sbin/amcrypt: aespipe was not found in /usr/sbin:/usr/libexec/amanda:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/sbin:/usr/sbin:/sbin:/usr/ucb:/opt/csw/bin
  \--------
I'd appreciate any advice you might have that could resolve the above situation. Thanks in advance!!