Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 35

Thread: amdump creates no backup

  1. #11
    Join Date
    May 2011
    Posts
    32

    Default

    Hello again.

    Woohsa a part success.
    This time i was able to amrecover and set a disk and it accepted it.
    So the index problem is solved(i hope).
    But i encounterd a strange phenomen.
    I tried to amcheck my conf but the client check ran on a disc.
    I didn't change anything in the amandahost files, etc... so i just restarted the xinetd service and voila the check ran through without a problem.

    Anyways. So i tried to extract my backups in a test dir. This is what was displayed:

    Code:
    root@amanda-client:/test # /usr/sbin/amrecover testbu -t amanda-server -s amanda-server
    AMRECOVER Version 2.5.0p2. Contacting server on amanda-server ...
    220 amanda-server AMANDA index server (2.5.0p2) ready.
    200 Access OK
    Setting restore date to today (2011-05-26)
    200 Working date set to 2011-05-26.
    Scanning /backups/amanda...
    200 Config set to testbu.
    200 Dump host set to amanda-client.
    Trying disk / ...
    Trying disk rootfs ...
    Can't determine disk and mount point from $CWD '/test'
    amrecover> setdisk /etc
    200 Disk set to /etc.
    amrecover> add *
    Added dir /yum at date 2011-05-26
    Added dir /yum.repos.d at date 2011-05-26
    Added /yum.conf
    Added dir /xinetd.d at date 2011-05-26
    Added /xinetd.conf
    Added dir /vmware-tools at date 2011-05-26
    Added /virc
    Added dir /udev at date 2011-05-26
    Added /termcap
    Added /tcsd.conf
    Added /syslog.conf
    Added /sysctl.conf
    Added dir /sysconfig at date 2011-05-26
    Added /sudoers.org
    Added /sudoers
    Added dir /ssh at date 2011-05-26
    Added dir /snmp at date 2011-05-26
    Added dir /skel at date 2011-05-26
    Added /shells
    Added /shadow-
    Added /shadow
    Added /sestatus.conf
    Added /services.org
    Added /services
    Added /sensors.conf
    Added dir /selinux at date 2011-05-26
    Added dir /security at date 2011-05-26
    Added /securetty.org
    Added /securetty
    Added /scsi_id.config
    Added dir /sasl2 at date 2011-05-26
    Added dir /rwtab.d at date 2011-05-26
    Added /rwtab
    Added dir /rpm at date 2011-05-26
    Added /rpc
    Added /resolv.conf
    Added /request-key.conf
    Added /redhat-release
    Added /rc6.d
    Added /rc5.d
    Added /rc4.d
    Added /rc3.d
    Added /rc2.d
    Added /rc1.d
    Added /rc0.d
    Added /rc.sysinit
    Added /rc.local
    Added dir /rc.d at date 2011-05-26
    Added /rc
    Added /protocols
    Added /profile.org
    Added dir /profile.d at date 2011-05-26
    Added /profile
    Added /printcap
    Added dir /prelink.conf.d at date 2011-05-26
    Added /prelink.conf
    Added /prelink.cache
    Added dir /ppp at date 2011-05-26
    Added dir /pm at date 2011-05-26
    Added dir /pki at date 2011-05-26
    Added /passwd-
    Added /passwd
    Added dir /pango at date 2011-05-26
    Added dir /pam.d at date 2011-05-26
    Added dir /opt at date 2011-05-26
    Added dir /openldap at date 2011-05-26
    Added dir /ntp at date 2011-05-26
    Added /ntp.conf.org
    Added /ntp.conf
    Added /nsswitch.conf.org
    Added /nsswitch.conf
    Added /nscd.conf
    Added dir /netplug at date 2011-05-26
    Added dir /netplug.d at date 2011-05-26
    Added /multipath.conf
    Added /mtab
    Added /motd
    Added dir /modprobe.d at date 2011-05-26
    Added /modprobe.conf~
    Added /modprobe.conf.BeforeVMwareToolsInstall
    Added /modprobe.conf
    Added /mke2fs.conf
    Added /man.config
    Added dir /makedev.d at date 2011-05-26
    Added /mail.rc
    Added dir /lvm at date 2011-05-26
    Added dir /logrotate.d at date 2011-05-26
    Added /logrotate.conf
    Added /loginusers
    Added /login.defs
    Added /localtime
    Added /libuser.conf
    Added /libaudit.conf
    Added /ldap.conf.org
    Added /ldap.conf
    Added dir /ld.so.conf.d at date 2011-05-26
    Added /ld.so.conf
    Added /ld.so.cache
    Added /krb5.conf
    Added /issue.net
    Added /issue
    Added dir /iproute2 at date 2011-05-26
    Added /inputrc
    Added /inittab.org
    Added /inittab
    Added /initlog.conf
    Added /init.d
    Added /hosts.org
    Added /hosts.deny
    Added /hosts.allow
    Added /hosts
    Added /host.conf
    Added dir /hal at date 2011-05-26
    Added dir /gtk-2.0 at date 2011-05-26
    Added /gshadow-
    Added /gshadow
    Added /grub.conf
    Added /group-
    Added /group
    Added dir /gcrypt at date 2011-05-26
    Added /fstab
    Added /freshclam.conf
    Added dir /fonts at date 2011-05-26
    Added /filesystems
    Added /exports
    Added /environment
    Added dir /dev.d at date 2011-05-26
    Added dir /depmod.d at date 2011-05-26
    Added dir /default at date 2011-05-26
    Added dir /dbus-1 at date 2011-05-26
    Added /csh.login
    Added /csh.cshrc
    Added /crontab
    Added dir /cron.weekly at date 2011-05-26
    Added dir /cron.monthly at date 2011-05-26
    Added dir /cron.hourly at date 2011-05-26
    Added /cron.deny
    Added dir /cron.daily at date 2011-05-26
    Added dir /cron.d at date 2011-05-26
    Added dir /blkid at date 2011-05-26
    Added /bashrc
    Added /amandates
    Added dir /amanda at date 2011-05-26
    Added dir /alternatives at date 2011-05-26
    Added /aliases
    Added /aide.conf
    Added dir /adsm at date 2011-05-26
    Added /adjtime
    Added dir /X11 at date 2011-05-26
    Added /TIVGUID
    Added /DIR_COLORS.xterm
    Added /DIR_COLORS
    Added /.pwd.lock
    Added dir / at date 2011-05-26
    amrecover> extract
    
    Extracting files using tape drive changer on host amanda-server.
    The following tapes are needed: testbu-5
    
    Restoring files into directory /test
    Continue [?/Y/n]? Y
    
    Extracting files using tape drive changer on host amanda-server.
    Load tape testbu-5 now
    Continue [?/Y/n/s/t]? Y
    amrecover: Could not read from control socket: Success
    So my guess is that something goes wrong with the changer. Or is it a socket error?

  2. #12
    Join Date
    May 2011
    Posts
    32

    Default

    Ok i somehow succeded in telling amrecove wich tapedive it should use:



    Code:
    amrecover> extract
    Extract list empty - No files to extract!
    amrecover> add *
    Added dir /yum at date 2011-05-26
    Added dir /yum.repos.d at date 2011-05-26
    Added /yum.conf
    Added dir /xinetd.d at date 2011-05-26
    Added /xinetd.conf
    Added dir /vmware-tools at date 2011-05-26
    Added /virc
    Added dir /udev at date 2011-05-26
    Added /termcap
    Added /tcsd.conf
    Added /syslog.conf
    Added /sysctl.conf
    Added dir /sysconfig at date 2011-05-26
    Added /sudoers.org
    Added /sudoers
    Added dir /ssh at date 2011-05-26
    Added dir /snmp at date 2011-05-26
    Added dir /skel at date 2011-05-26
    Added /shells
    Added /shadow-
    Added /shadow
    Added /sestatus.conf
    Added /services.org
    Added /services
    Added /sensors.conf
    Added dir /selinux at date 2011-05-26
    Added dir /security at date 2011-05-26
    Added /securetty.org
    Added /securetty
    Added /scsi_id.config
    Added dir /sasl2 at date 2011-05-26
    Added dir /rwtab.d at date 2011-05-26
    Added /rwtab
    Added dir /rpm at date 2011-05-26
    Added /rpc
    Added /resolv.conf
    Added /request-key.conf
    Added /redhat-release
    Added /rc6.d
    Added /rc5.d
    Added /rc4.d
    Added /rc3.d
    Added /rc2.d
    Added /rc1.d
    Added /rc0.d
    Added /rc.sysinit
    Added /rc.local
    Added dir /rc.d at date 2011-05-26
    Added /rc
    Added /protocols
    Added /profile.org
    Added dir /profile.d at date 2011-05-26
    Added /profile
    Added /printcap
    Added dir /prelink.conf.d at date 2011-05-26
    Added /prelink.conf
    Added /prelink.cache
    Added dir /ppp at date 2011-05-26
    Added dir /pm at date 2011-05-26
    Added dir /pki at date 2011-05-26
    Added /passwd-
    Added /passwd
    Added dir /pango at date 2011-05-26
    Added dir /pam.d at date 2011-05-26
    Added dir /opt at date 2011-05-26
    Added dir /openldap at date 2011-05-26
    Added dir /ntp at date 2011-05-26
    Added /ntp.conf.org
    Added /ntp.conf
    Added /nsswitch.conf.org
    Added /nsswitch.conf
    Added /nscd.conf
    Added dir /netplug at date 2011-05-26
    Added dir /netplug.d at date 2011-05-26
    Added /multipath.conf
    Added /mtab
    Added /motd
    Added dir /modprobe.d at date 2011-05-26
    Added /modprobe.conf~
    Added /modprobe.conf.BeforeVMwareToolsInstall
    Added /modprobe.conf
    Added /mke2fs.conf
    Added /man.config
    Added dir /makedev.d at date 2011-05-26
    Added /mail.rc
    Added dir /lvm at date 2011-05-26
    Added dir /logrotate.d at date 2011-05-26
    Added /logrotate.conf
    Added /loginusers
    Added /login.defs
    Added /localtime
    Added /libuser.conf
    Added /libaudit.conf
    Added /ldap.conf.org
    Added /ldap.conf
    Added dir /ld.so.conf.d at date 2011-05-26
    Added /ld.so.conf
    Added /ld.so.cache
    Added /krb5.conf
    Added /issue.net
    Added /issue
    Added dir /iproute2 at date 2011-05-26
    Added /inputrc
    Added /inittab.org
    Added /inittab
    Added /initlog.conf
    Added /init.d
    Added /hosts.org
    Added /hosts.deny
    Added /hosts.allow
    Added /hosts
    Added /host.conf
    Added dir /hal at date 2011-05-26
    Added dir /gtk-2.0 at date 2011-05-26
    Added /gshadow-
    Added /gshadow
    Added /grub.conf
    Added /group-
    Added /group
    Added dir /gcrypt at date 2011-05-26
    Added /fstab
    Added /freshclam.conf
    Added dir /fonts at date 2011-05-26
    Added /filesystems
    Added /exports
    Added /environment
    Added dir /dev.d at date 2011-05-26
    Added dir /depmod.d at date 2011-05-26
    Added dir /default at date 2011-05-26
    Added dir /dbus-1 at date 2011-05-26
    Added /csh.login
    Added /csh.cshrc
    Added /crontab
    Added dir /cron.weekly at date 2011-05-26
    Added dir /cron.monthly at date 2011-05-26
    Added dir /cron.hourly at date 2011-05-26
    Added /cron.deny
    Added dir /cron.daily at date 2011-05-26
    Added dir /cron.d at date 2011-05-26
    Added dir /blkid at date 2011-05-26
    Added /bashrc
    Added /amandates
    Added dir /amanda at date 2011-05-26
    Added dir /alternatives at date 2011-05-26
    Added /aliases
    Added /aide.conf
    Added dir /adsm at date 2011-05-26
    Added /adjtime
    Added dir /X11 at date 2011-05-26
    Added /TIVGUID
    Added /DIR_COLORS.xterm
    Added /DIR_COLORS
    Added /.pwd.lock
    Added dir / at date 2011-05-26
    amrecover> extract
    
    Extracting files using tape drive testbu-5 on host amanda-server.
    The following tapes are needed: testbu-5
    
    Restoring files into directory /test
    Continue [?/Y/n]? Y
    
    Extracting files using tape drive testbu-5 on host amanda-server.
    Load tape testbu-5 now
    Continue [?/Y/n/s/t]? t
    New tape device [?]: file:/backups/testbu/slots/data
    Using tape "file:/backups/testbu/slots/data" from server amanda-server.
    Continue [?/Y/n/s/t]? y
    Please insert tape testbu-5. Continue? [Y|n]: y
    Please insert tape testbu-5. Continue? [Y|n]: y
    Please insert tape testbu-5. Continue? [Y|n]: y
    Please insert tape testbu-5. Continue? [Y|n]: y
    i say y, but it does nothing.

    i manually loaded the tape (here it's tape 5) !

    Code:
    amanda@amanda-server:~ $ /usr/sbin/amtape testbu slot 5
    changer: got exit: 0 str: 5 file:/backups/testbu/slots
    amtape: changed to slot 5 on file:/backups/testbu/slots
    amanda@amanda-server:~ $ /usr/sbin/ammt -t file:/backups/testbu/slots/ rewind
    amanda@amanda-server:~ $ /usr/sbin/amadmin testbu find
    Scanning /backups/amanda...
    
    date       host          disk lv tape or file file part status
    2011-05-26 amanda-client /etc  0 testbu-5        1   -- OK
    amanda@amanda-server:~ $ /usr/sbin/amtape testbu slot 5
    changer: got exit: 0 str: 5 file:/backups/testbu/slots
    amtape: changed to slot 5 on file:/backups/testbu/slots
    amanda@amanda-server:~ $ /usr/sbin/ammt -t file:/backups/testbu/slots/ rewind
    amanda@amanda-server:~ $ /usr/sbin/amadmin testbu find
    Scanning /backups/amanda...
    
    date       host          disk lv tape or file file part status
    2011-05-26 amanda-client /etc  0 testbu-5        1   -- OK
    so it is the correct tape. it is loaded. what am i missing?


    and a side-question: were are the debug files? i dont have a /tmp/amanda directory...

    ######

    i just finished restoring a tape manually:

    Code:
    /usr/sbin/amrestore file:/backups/testbu/slots -l testbu-5
    amrestore:   1: restoring amanda-client._etc.20110526.0
    amrestore:   2: reached end of tape: date 20110526
    amanda@amanda-server:~ $ ls
    amanda-client._etc.20110526.0  extracted
    amanda@amanda-server:~ $
    so i conclude that there must be a configuration issue with amrestore... Anyone a guess?
    Last edited by bv_chris; May 26th, 2011 at 03:32 AM.

  3. #13
    Join Date
    May 2011
    Posts
    32

    Default

    Hello again.
    After another week of working with amanda i hit a new problem.
    As i described in a earlier post, i wasn't able to recover a backup but restore it.
    Now i hit a dead end again, when i try to create a new backup and amrecover it.
    Code:
    AMRECOVER Version 2.5.0p2. Contacting server on amanda-server ...
    220 amanda-server AMANDA index server (2.5.0p2) ready.
    200 Access OK
    Setting restore date to today (2011-05-31)
    200 Working date set to 2011-05-31.
    Scanning /backups/amanda...
    200 Config set to testbu.
    200 Dump host set to amanda-client.
    Trying disk / ...
    Trying disk rootfs ...
    Can't determine disk and mount point from $CWD '/'
    amrecover> setdisk /etc
    200 Disk set to /etc.
    No index records for disk for specified date
    If date correct, notify system administrator
    amrecover> quit
    200 Good bye.
    The log on the server says:
    Code:
    amtrmidx: debug 1 pid 21804 ruid 33 euid 33: start at Tue May 31 11:49:33 2011
    /usr/lib64/amanda/amtrmidx: version 2.5.0p2
    amanda-client /test
    rm /backups/testbu/index/amanda-client/_test/20110531_0.gz
    amtrmidx: pid 21804 finish time Tue May 31 11:49:33 2011
    Why does it delete the index file? That shouldn't happen.

    Another problem is. I need to restart the xinetd service on the client after roughly 5mins otherwise the server can't connect to it anymore. I don't know what this is causing, any guesses?

  4. #14
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Amanda remove index file if the backup is no longer on tape.
    Are you sure the backup succeeded and is still on tape?

  5. #15
    Join Date
    May 2011
    Posts
    32

    Default

    Code:
    amanda@amanda-server:/ $ /usr/sbin/amadmin testbu find
    Scanning /backups/amanda...
    
    date       host          disk  lv tape or file file part status
    2011-05-31 amanda-client /test  0 testbu-1        1   -- OK
    So it should be there.
    Code:
    amanda@amanda-server:/ $ ls  -oast /backups/testbu/index/amanda-client/_test/
    8 drwxr-sr-x 2 amanda 4096 May 31 12:13 .
    8 -rw------- 1 amanda  309 May 31 12:00 20110531_0
    8 drwxrwxrwx 4 amanda 4096 May 31 11:39 ..
    i reseted my tapes with relabeling them. but don't i need to delete other things too?
    i read somewhere that for amrecover the logs are required too?

  6. #16
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    In amrecover you did: setdisk /etc
    But you show index for /test dle?
    Please post information for same dle, do not mix dle in bug report.

  7. #17
    Join Date
    May 2011
    Posts
    32

    Default

    ok. I don't know what i did know. But setdisk gives me no index error but it stops again at extracting the data...
    Man it is so confusing
    Code:
    AMRECOVER Version 2.5.0p2. Contacting server on amanda-server ...
    220 amanda-server AMANDA index server (2.5.0p2) ready.
    200 Access OK
    Setting restore date to today (2011-05-31)
    200 Working date set to 2011-05-31.
    Scanning /backups/amanda...
    200 Config set to testbu.
    200 Dump host set to amanda-client.
    Trying disk / ...
    Trying disk rootfs ...
    Can't determine disk and mount point from $CWD '/'
    amrecover> setdisk /test
    200 Disk set to /test.
    amrecover> setdisk /etc
    501 Disk amanda-client:/etc is not in your disklist.
    amrecover> setdisk /tset
    501 Disk amanda-client:/tset is not in your disklist.
    amrecover> setdisk /test
    200 Disk set to /test.
    amrecover> add *
    Added /test_9
    Added /test_8
    Added /test_7
    Added /test_6
    Added /test_5
    Added /test_4
    Added /test_3
    Added /test_22
    Added /test_21
    Added /test_20
    Added /test_2
    Added /test_19
    Added /test_18
    Added /test_17
    Added /test_16
    Added /test_15
    Added /test_14
    Added /test_13
    Added /test_12
    Added /test_11
    Added /test_10
    Added /test_1
    Added /pewpew_9
    Added /pewpew_8
    Added /pewpew_7
    Added /pewpew_6
    Added /pewpew_5
    Added /pewpew_4
    Added /pewpew_3
    Added /pewpew_2
    Added /pewpew_10
    Added /pewpew_1
    Added /pewpew_
    Added /pewpew
    Added dir / at date 2011-05-31
    amrecover> extract
    
    Extracting files using tape drive changer on host amanda-server.
    The following tapes are needed: testbu-1
    
    Restoring files into directory /
    Continue [?/Y/n]? n
    amrecover> lcd /test
    amrecover> extract
    
    Extracting files using tape drive changer on host amanda-server.
    The following tapes are needed: testbu-1
    
    Restoring files into directory /test
    Continue [?/Y/n]? y
    
    Extracting files using tape drive changer on host amanda-server.
    Load tape testbu-1 now
    Continue [?/Y/n/s/t]? y
    amrecover: Could not read from control socket: Success
    and it brakes.
    I tryed some things, see in above post, but to no chance. Works not.

  8. #18
    Join Date
    May 2011
    Posts
    32

    Default

    Code:
    tpchanger "chg-disk"    # the tape-changer glue script
    tapedev "file:/backups/testbu/slots"    # the no-rewind tape device to be used
    #rawtapedev "/dev/null" # the raw device to be used (ftape only)
    #changerfile "/etc/amanda/DailySet1/changer"
    #changerfile "/etc/amanda/DailySet1/changer-status"
    changerfile "/etc/amanda/testbu/changer"
    changerdev "/backups/testbu/slots"
    when i say: settape xxx what does it expect? the "changer" ? or "chg-disk"?

  9. #19
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    settape require a device (tapedev) unless you do the following to allow amrecover to works with the changer:

    Add the following in amanda.conf:
    amrecover_changer "changer"

    Then in amrecover:
    settape changer

  10. #20
    Join Date
    May 2011
    Posts
    32

    Default

    i have this in my conf.
    amrecover-changer "changer"

    so theoretically i can use changer or file:/backups/testbu/slots

    but both options quote me :
    Code:
    amrecover> settape file:/backups/testbu/slots
    Using tape "file:/backups/testbu/slots" from server amanda-server.
    amrecover> extract
    
    Extracting files using tape drive file:/backups/testbu/slots on host amanda-server.
    The following tapes are needed: testbu-1
    
    Restoring files into directory /test
    Continue [?/Y/n]? y
    
    Extracting files using tape drive file:/backups/testbu/slots on host amanda-server.
    Load tape testbu-1 now
    Continue [?/Y/n/s/t]? y
    amrecover: Could not read from control socket: Success
    and

    Code:
    amrecover> settape changer
    Using tape "changer" from server amanda-server.
    amrecover> extract
    
    Extracting files using tape drive changer on host amanda-server.
    The following tapes are needed: testbu-1
    
    Restoring files into directory /test
    Continue [?/Y/n]? y
    
    Extracting files using tape drive changer on host amanda-server.
    Load tape testbu-1 now
    Continue [?/Y/n/s/t]? y
    amrecover: Could not read from control socket: Success
    the amrecover log contains :
    Code:
    amrecover: bind_portrange2: trying port=703
    amrecover: stream_client_privileged: connected to 192.168.1.242.10083
    amrecover: stream_client_privileged: our side is 0.0.0.0.703
    amrecover: try_socksize: receive buffer size is 65536
    amrecover: Could not read from control socket: Success
    
    amrecover: pid 1557 finish time Tue May 31 12:44:32 2011
    I'm guessing that it has something to do with the .amandahosts or xinetd services, but i don't know what.
    Any cmd or advice?

    The port 10083 is used by
    tcp 0 0 0.0.0.0:10083 0.0.0.0:* LISTEN
    tcp 0 0 *:amidxtape *:* LISTEN
    for what is amidxtape needed?
    and why can't the client connect through it?
    .amandahost on amanda-server:
    Code:
    amanda-client root amindexd amidxtaped
    Last edited by bv_chris; May 31st, 2011 at 03:41 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •