Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Help me get started

  1. #1
    Join Date
    May 2011
    Posts
    8

    Default Help me get started

    Be gentle now, I'm new here.

    I have a basic Ubuntu system that I want to back up to a stand alone IBM LTO3 drive. I want to do weekly incrimentals (Sunday) and a full on the first Sunday of each month. I want to keep 3 copies grandfather-father-son and recycle after 90 days.

    I installed Amanda from the Ubuntu Software Center. It installed amanda-common, and amanda-server 1:3.2.1-1.

    Now what? Is that considered 3.2.x?

    I tried running the amserverconfig script while guessing at the params but it failed. I'm new to Perl so I really don't know how to troubleshoot what went wrong.

    When I try to search the web I get hits from 2003 - 2010. I found the "15 Steps ..." HOWTO but I couldn't figure out what steps to skip since I only have one machine and am using tape.

    I almost had Bacula running but I ran into problems trying to figure out how to control it. I hope my experience with Amanda will be different.

    Can someone point me in the direction on how to get started?

  2. #2
    Join Date
    May 2011
    Posts
    8

    Default

    I'm going through the Build a "Basic Configuration" and got an error:

    $ amcheck MyConfig
    Amanda Tape Server Host Check
    -----------------------------
    NOTE: tapelist will be created on the next run.
    Holding disk /amanda/holding: 6488064 kB disk space available, using 51200 kB as requested
    slot 0: contains an empty volume
    Will write label 'MyData01' to new volume in slot 0.
    NOTE: skipping tape-writable test
    NOTE: conf info dir /amanda/state/curinfo does not exist
    NOTE: it will be created on the next run.
    NOTE: index dir /amanda/state/index does not exist
    NOTE: it will be created on the next run.
    Server check took 0.122 seconds
    amcheck-clients: error: couldn't exec /usr/lib/amanda/amandad: No such file or directory

    Amanda Backup Client Hosts Check
    --------------------------------
    WARNING: localhost: selfcheck request failed: EOF on read from localhost
    Client check: 1 host checked in 0.002 seconds. 1 problem found.

    (brought to you by Amanda 3.2.1)

    Any ideas? The error is right there is no amandad in usr lib.

  3. #3
    Join Date
    May 2011
    Posts
    8

    Default

    Gave up on the error above and went straight to amserverconfig. I now get this error

    "amserverconfig: ERROR: copy dumptypes failed: No such file or directory"

    that comes from this part of the script:

    &check_gnutarlist_dir;

    # copy dumptypes and tapetypes files if none exists.
    my $dtype="$confdir/template.d/dumptypes";
    my $ttype="$confdir/template.d/tapetypes";

    unless ( -e $dtype ) {
    copy("$templatedir/dumptypes", $dtype ) ||
    &log_and_die ("ERROR: copy dumptypes failed: $!\n", 1);
    }

    I don't know Perl and was hoping someone could tell me what the above code does. I did make sure that the variables were set right in the Paths.pm file. I had to make two corrections, but it didn't change the error.

    Is there anybody out there?

  4. #4
    Join Date
    May 2011
    Posts
    8

    Default

    Besides having a nice conversation WITH MYSELF this thread at least can function as a journal of the issues I've had getting Amanda running.

    My latest issue happens when I try to label a tape or run the amcheck on my configuration.

    # amcheck SingleDrive

    I get an error that looks like the "tapelist dir" path looks hosed.

    ERROR: tapelist dir /etc/amanda/SingleDrive/@CONFIG_DIR/SingleDrive: not writable

    The problems looks to me like the path above is not formed correctly. "@CONFIG_DIR" should be "/etc/amanda".

    Hello.. can anybody hear me?

  5. #5
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    What is the tapelist setting in amanda.conf:
    amgetconf SingleDrive tapelist

  6. #6
    Join Date
    May 2011
    Posts
    8

    Default

    I fixed the path issues in Paths.pm file:

    $amdatadir
    and
    $localstatedir

    That got me to where I am now:

    __________________________________________________ __________
    root@resq-vault:/etc/amanda/SingleDrive# amcheck SingleDrive
    Amanda Tape Server Host Check
    -----------------------------
    slot 1: volume 'MonthlyTape1'
    Will write to volume 'MonthlyTape1' in slot 1.
    NOTE: skipping tape-writable test
    WARNING: tapecycle (4) <= runspercycle (4).
    NOTE: host info dir /etc/amanda/SingleDrive/curinfo/resq-vault does not exist
    NOTE: it will be created on the next run.
    NOTE: index dir /etc/amanda/SingleDrive/index/resq-vault does not exist
    NOTE: it will be created on the next run.
    Server check took 0.134 seconds

    Amanda Backup Client Hosts Check
    --------------------------------
    WARNING: resq-vault: selfcheck request failed: Connection refused
    Client check: 1 host checked in 10.021 seconds. 1 problem found.

    __________________________________________________ __________

    I don't have any clients. Is there a daemon that is not running? resq-vault is my server.

  7. #7
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Which auth are you using?
    check that xinetd is correctly set for that auth,

  8. #8
    Join Date
    May 2011
    Posts
    8

    Default

    Hi martineau,

    I'm running Ubuntu and it looks like my server is using inetd, just FYI.

    The auth is set to BSD.

  9. #9
    Join Date
    May 2011
    Posts
    8

    Default

    Changed auth to BSDTCP, no help. See debug below:


    Fri May 27 15:55:42 2011: amcheck-clients: security_close(handle=0x9b3e00, driver=0x7f5b71dc7940 (BSDTCP))
    Fri May 27 15:55:42 2011: amcheck-clients: security_stream_close(0x9bc7d0)
    Fri May 27 15:55:47 2011: amcheck-clients: security_handleinit(handle=0x9b4870, driver=0x7f5b71dc7940 (BSDTCP))
    Fri May 27 15:55:47 2011: amcheck-clients: security_streaminit(stream=0x9bc760, driver=0x7f5b71dc7940 (BSDTCP))
    Fri May 27 15:55:47 2011: amcheck-clients: connect_port: Skip port 512: owned by exec.
    Fri May 27 15:55:47 2011: amcheck-clients: connect_port: Skip port 513: owned by login.
    Fri May 27 15:55:47 2011: amcheck-clients: connect_port: Skip port 514: owned by shell.
    Fri May 27 15:55:47 2011: amcheck-clients: connect_port: Skip port 515: owned by printer.
    Fri May 27 15:55:47 2011: amcheck-clients: make_socket opening socket with family 2
    Fri May 27 15:55:47 2011: amcheck-clients: connect_port: Try port 516: available - Success
    Fri May 27 15:55:47 2011: amcheck-clients: connect_portrange: Connect from 0.0.0.0.516 failed: Connection refused
    Fri May 27 15:55:47 2011: amcheck-clients: connect_portrange: connect to 127.0.0.1.10080 failed: Connection refused
    Fri May 27 15:55:47 2011: amcheck-clients: stream_client: Could not bind to port in range 512-1023.
    Fri May 27 15:55:47 2011: amcheck-clients: security_seterror(handle=0x9b4870, driver=0x7f5b71dc7940 (BSDTCP) error=Connection refused)
    Fri May 27 15:55:47 2011: amcheck-clients: security_close(handle=0x9b4870, driver=0x7f5b71dc7940 (BSDTCP))
    Fri May 27 15:55:47 2011: amcheck-clients: security_stream_close(0x9bc760)
    Fri May 27 15:55:47 2011: amcheck: pid 2448 finish time Fri May 27 15:55:47 2011



    Amanda = Pain

  10. #10
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    What is the inetd setting? Do you restarted the inetd deamon.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •