I am getting the following error installing Amanda 3.2.2-1 on Amazon linux (centos 5) (Installing in a VPC on in the Amazon cloud)

--> Finished Dependency Resolution
Error: Package: amanda-backup_server-3.2.2-1.rhel5.i386 (/amanda-backup_server-3.2.2-1.rhel5.i386)
Requires: libcurl.so.3
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I have verified that curl is installed.

Package curl-7.19.7-16.18.amzn1.i686 already installed and latest version

Thanks