Results 1 to 5 of 5

Thread: ssh auth: why port 10080 is opened?

  1. #1
    Join Date
    Mar 2011
    Posts
    3

    Default ssh auth: why port 10080 is opened?

    Hello!

    I've read this article: [url]http://wiki.zmanda.com/index.php/How_To:Set_up_transport_encryption_with_SSH[/url]

    Now I don't know why amanda opens the 10080 port?
    The article says, that amanda server logs in via ssh port 22 (or any other described in .ssh/config) and runs amandad. Why do we need an additional port?

    Thanks!

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Amanda do not use the 10080 port with ssh auth.
    Why do you say it open it? Always prove what you say, post the debug files.

  3. #3
    Join Date
    Mar 2011
    Posts
    3

    Default

    Code:
    $ cat /etc/inetd.conf 
    amanda stream tcp nowait amandabackup  /usr/local/libexec/amanda/amandad amandad -auth=ssh amdump
    here ssh auth is enabled

    and now restarting inetd:

    Code:
    $ pfexec svcadm disable inetd
    
    $ ssh localhost -p 10080 -v
    Sun_SSH_1.5, SSH protocols 1.5/2.0, OpenSSL 0x009080ef
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Rhosts Authentication disabled, originating port will not be trusted.
    debug1: ssh_connect: needpriv 0
    debug1: Connecting to localhost [127.0.0.1] port 10080.
    debug1: connect to address 127.0.0.1 port 10080: Connection refused
    ssh: connect to host localhost port 10080: Connection refused
    
    $ pfexec svcadm enable inetd
    
    $ ssh localhost -p 10080 -v
    Sun_SSH_1.5, SSH protocols 1.5/2.0, OpenSSL 0x009080ef
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Rhosts Authentication disabled, originating port will not be trusted.
    debug1: ssh_connect: needpriv 0
    debug1: Connecting to localhost [127.0.0.1] port 10080.
    debug1: Connection established.
    debug1: identity file /export/home/ahomyakov/.ssh/identity type -1
    debug1: identity file /export/home/ahomyakov/.ssh/id_rsa type -1
    debug1: identity file /export/home/ahomyakov/.ssh/id_dsa type -1
    
    ^C
    $
    So the port is opened

  4. #4
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    inetd configuration is not needed for ssh, you can remove it.

    You try to connect to port 10080, amanda don't do that with ssh.

    amanda ssh to the client with the normal ssh port (22). to execute amandad on the client.

    You wrote a bogus inetd entry to open the 10080 port and complains it is open? The solution is to remove the inetd entry.

    The wiki page never says that you must have an inetd entry? I don't know you think you need one?

  5. #5
    Join Date
    Mar 2011
    Posts
    3

    Default

    Thank you! The problem is solved

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •