Results 1 to 2 of 2

Thread: Error autolabel

  1. #1

    Default Error autolabel

    Hello,

    I'm trying for the first time to configure Amanda. I'm following step by step the tutorial in this page :

    [url]http://wiki.zmanda.com/index.php/GSWA/Build_a_Basic_Configuration[/url]

    However I meet an error using amcheck MyConfig

    Code:
    # amcheck MyConfig
    "/etc/amanda/MyConfig/amanda.conf", line 8: configuration keyword expected
    amcheck: errors processing config file
    And here is my amanda.conf config file :

    Code:
    org "MyConfig"
    infofile "/mnt/sauvegardes/amanda/state/curinfo"
    logdir "/mnt/sauvegardes/amanda/state/log"
    indexdir "/mnt/sauvegardes/amanda/state/index"
    
    tpchanger "chg-disk:/mnt/sauvegardes/amanda/vtapes"
    labelstr "MyData[0-9][0-9]"
    autolabel "MyData%%" EMPTY VOLUME_ERROR
    tapecycle 4
    dumpcycle 3 days
    amrecover_changer "changer"
    dumpuser "backup"
    
    tapetype "TEST-TAPE"
    define tapetype TEST-TAPE {
      length 100 mbytes
      filemark 4 kbytes
    }
    
    define dumptype simple-gnutar-local {
        auth "local"
        compress none
        program "GNUTAR"
    }
    
    holdingdisk hd1 {
        directory "/mnt/sauvegardes/amanda/holding"
        use 50 mbytes
        chunksize 1 mbyte
    }
    I've tried without empty and/or volume_error at the autolabel line, but I always get the same error.

    I'm at the very early step of using Amanda, and I need some help to go on far away

    Thanks a lot

  2. #2
    Join Date
    Aug 2011
    Posts
    1

    Default A quick fix...

    I was in the same position.

    My work around was to comment out the following line:

    #autolabel "MyData%%" EMPTY VOLUME_ERROR

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •