Results 1 to 5 of 5

Thread: ZRM with RDS?

  1. #1
    Join Date
    Feb 2011

    Question ZRM with RDS? [SOLVED]

    I'm trying to setup ZRM to backup Amazon's Relational Database Service (RDS) however RDS apparently doesn't support mysqladmin's flush-logs command. Is there anyway, in the mysql-zrm.conf or otherwise, to skip the "Flushing logs" phase?

    Last edited by colinc; May 25th, 2011 at 06:52 AM. Reason: Marked as solved

  2. #2
    Join Date
    Oct 2005


    We need to flush-logs to make sure database changes are written to disk. Otherwise, backups will not be consistent. Probably, this is not required for Amazon RDS.

    There is no configuration option to skip this step. You will have to change the code. Let us know if you need help.

  3. #3


    I would like to do exactly this. can you post to the forum a diff or instructions on how to change the code to allow this?

    I am in the process now of migrating from my own mysql installation in ec2 and have been unable to backup or restore to and from amazon rds.

    Of course I assume that I will only be able to do full backups and would not be able to do incrementals.

    Great if this is a supported configuration in zmanda zrm. Amazon RDS has great backup capability, but this is not of use in situations where the service is down like happened in April.

  4. #4
    Join Date
    Feb 2011

    Post RDS patch

    Thanks for reminding me, I meant to do this a while ago and forgot.

    You're correct that it's only for full backups as there's no way to access the RDS binary logs (even though we know RDS is using them internally).

    This patch is for 2.2.0 but I'm sure you could manually add the same 3 lines to an older version and achieve the same results.

    After you've applied the patch you can add the following to your RDS related ZRM configuration file(s):


    This patch has been used for over 3 months now, backing up 3 separate RDS servers nightly and I've had no issues so far (the backups are checked for integrity weekly). Obviously proceed at your own risk and check your backups often (especially at first) to make sure everything is working as you expect it to.
    Attached Files Attached Files

  5. #5


    Thanks for the patch! I'll go ahead and try it out.

    I assume I'll need to apply the config change manually, where should I look for that file?

    In the configuration, should the 'copy' plugin be set to socket or ssh? does that matter?

    Any issues with the agent not running on the machine?

    Am I better off running this backup against read replicas to not cause table locks or other performance issues in such a setup?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts