Results 1 to 10 of 10

Thread: amanda reports

  1. #1

    Default amanda reports

    Is there a way to configure amanda to send the emails of dump summary at a particular time? For example I take backups at night around 9pm, I have setup the job in cron as "amdump backups" but I want the email that follows the amdump to be sent in the morning like around 9am instead of sending the email of dump summary right after it finishes dumping.

  2. #2

    Default

    Schedule "amreport -M ...." command in the crontab. Please see amreport man page for command line options http://wiki.zmanda.com/man/amreport.8.html

  3. #3

    Default

    Thanks for replying Paddy.

    when I issue the amreport command without any logfile options on the command prompt, it should email me the report from the most recent logfile, but instead i get an email from amanda with subject like "AMANDA MAIL REPORT FOR BogusMonth 0, 0". The command I used was this

    $amreport backups -M sdffs@domain.com

    For your information, I installed amanda as an RPM. I have the log directory specified in /etc/amanda/backups/amanda.conf.

  4. #4
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    840

    Default

    As the run is done, you must specify on the command line which log file amreport must use to generate the report.

  5. #5

    Default

    Thanks it works now. I first had to cd into the log directory. Then I ran the following command.

    $amreport backups -M sffdss@domain.com -l $(ls |grep `date +"%Y%m%d" --date="yesterday"`)

  6. #6

    Default

    when I put this command in cron it doesnt work. Not sure whats the problem.

    55 8 * * 1-5 cd /usr/adm/backups/logdir;/usr/sbin/amreport backups -M sffdss@domain.com -l $(ls|grep `date +"%Y%m%d" --date="yesterday"`)

  7. #7

    Default

    Nevermind I got it now. Searched on google. Had to add backslash before each of the % characters.

    So the new command now looks like this.


    55 8 * * 1-5 cd /usr/adm/backups/logdir;/usr/sbin/amreport backups -M sffdss@domain.com -l $(ls|grep `date +"\%Y\%m\%d" --date="yesterday"`)

  8. #8

    Default

    Even though I can instruct amanda to email reports at a particular time, how can I prevent amdump not to email the report right after its done?

    Because now I am getting a report right after amdump is done and also one in the morning (from the cronjob that I have setup).

  9. #9

    Default

    See send-amreport-on parameter in amanda.conf. Set it to never. amflush/amdump will
    not send you emails.

    In your crontab entry use amreport -o option to override the parameter with suitable
    value for send-amreport-on

  10. #10

    Default

    Thanks Paddy, I'll give it a try.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •