Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Failed to create backup directory

  1. #1

    Default Failed to create backup directory

    Hi,

    I installed zmanda cloud backup in my servers and started the backup. It starts the backup to a mapped network drive. But once scheduled the backup, it shows an error "failed to create backup directory and always fails. Happens in all 3 servers installed.

    Please help me to fix this issue at the earliest.

  2. #2
    Join Date
    Sep 2008
    Posts
    112

    Default

    Hi,
    ZCB schedules are run under the SYSTEM user context. This user does not have network privileges.
    To resolve the issue, change the user for schedules to "amandabackup".

    1. Open Windows Task Scheduler or Scheduled Tasks.
    2. Identify the schedules created by ZCB.
    3. Go to the Properties of the schedules that fail.
    4. Change the user from SYSTEM to "amandabackup".

    Please let us know if this resolves the issue.

    Regards,
    Prashant Joshi

  3. #3

    Default

    Hi Prashant,

    This seems to be working. I changed the user in Scheduled Tasks to amandabackup. I started the backup manually and it seems to be completed successfully. I will keep this open and see if it works properly on scheduled time.

    Not sure if I can ask in the same thread, but I am not able to receive any email notifications from zmanda after completing the backup. I have given the same account details which I use in other services to send email notification. Is there any way to check what is happening?

  4. #4
    Join Date
    Sep 2008
    Posts
    112

    Default

    Hi,
    I would request you to open a support case for the email notification issue and upload the logs.

    Regards,
    Prashant

  5. #5

    Default

    Hi prashant,

    All the scheduled backup failed! I changed the user to amandabackup in the scheduled tasks. It runs perfectly and takes the backup upload to amazon, if I do it manually.

    Please let me know if I need to make further changes to fix this issue.

    PS: Email issue is fixed and am getting emails now, unfortunately for failed backup!
    Log:
    Backup start time : 2010/12/01 19:00:03
    Backup end time : 2010/12/01 19:00:03
    Total Bytes backed up : 0.00 KB
    Files on disk : 0
    Files in backup : 0
    Error Details : Failed to create backup directory.

  6. #6
    Join Date
    Sep 2008
    Posts
    112

    Default

    Hi,
    That is strange. Is the ZCB machine and the network share a part of any domain? What credentials is the "ZWCService" started with? If its a domain account, please run the schedules as the domain amandabackup user and give privileges to this user on the network share.

    In case, the schedules still have the same issue, I would request you to open a support case so that we can debug the issue.

    Regards,
    Prashant

  7. #7

    Default

    Hi prashant,
    Its a domain environment and the schedule user is domain\amandabackup
    Also i have given full access to the betwork drive and mapped
    To each server which i want to take the backup.

    I woukd really appreciate if you let me know on how to open
    A support case for this issue as none of my backup is happening
    automaticall which is bit scary.

  8. #8
    Join Date
    Oct 2005
    Posts
    1,559

    Default

    Hi,

    Please open a support case by logging in at [url]http://network.zmanda.com[/url] and clicking
    support tab.

    Also attach the logs collected by clicking Tools->Collect Logs to the case.

    thanks
    Paddy

  9. #9

    Default

    Thank a lot paddy,

    Case opened and attache log file too.

  10. #10

    Thumbs up

    Problem solved!

    Got help from Zmanda support. Issue turned out to be the path mentioned in the destination drive. In the destination local drive, I gave the mapped drive as the location. (X:\backuppath). This works when I run it manually from ZCB, but fails during scheduled tasks.

    This now changed with UNC path (\\servername\sharename) and all started working again perfectly!

    Thank you all for the support and help once again, and really appreciate Zmanda support team for the quick response.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •