Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Problem with mn-stage-beta-1 crashing - zmanda windows client

  1. #1
    Join Date
    Apr 2010
    Posts
    30

    Default Problem with mn-stage-beta-1 crashing - zmanda windows client

    I have a machine running windows 2003 Enterprise Edition with Service Pack 2. The Zmanda client is crashing once every few days. It will run, and then the zwcservice will simply shut down and the os issues a connection refused.

    It has done this numerous times. Checking the event viewer, there are no errors reported with the filesystem or hardware.

    I have turned on zmanda support debugging in the client, and have collected the core in the .cab file.

    May I send it to you for you to analyze?

  2. #2
    Join Date
    Apr 2010
    Posts
    30

    Default The version of the client

    Also should add that I am using Zmanda client 2.6.1.3.

  3. #3
    Join Date
    Oct 2005
    Posts
    1,559

    Default

    Can you please try the newer version 3.1?

    Paddy

  4. #4
    Join Date
    Apr 2010
    Posts
    30

    Default

    Even with the new client, 3.1, I am seeing it crash regularily once every several days. I have generated a .cab file. Is it ok if I submit it to you?

  5. #5
    Join Date
    Oct 2005
    Posts
    1,559

    Default

    In other post, you had mentioned that the problem does not occur when log level is
    debug. Is my understanding correct?

    Are you running windows client on a multi-processor? We are aware of problem at normal
    log level running on a multiprocessor. We are working on a fix for it.

    Paddy

  6. #6
    Join Date
    Apr 2010
    Posts
    30

    Default

    This is for a different machine. The other machine win-web6, and with log level full it backups up fine.

    Log level on this machine in this thread (mn-stage-beta-1) is on full and it still crashes.

  7. #7
    Join Date
    Sep 2006
    Posts
    72

    Default

    Quote Originally Posted by spyhunter View Post
    Even with the new client, 3.1, I am seeing it crash regularily once every several days. I have generated a .cab file. Is it ok if I submit it to you?
    Yes pl. submit it.

  8. #8
    Join Date
    Sep 2006
    Posts
    72

    Default

    We got the logs.

    ZWCService is crashing because it's not getting the required memory for allocation

    3936:1604:10/9/2010:18:10:281::FS: NTFS: Found File %1!s!3936:1604:10/9/2010:18:10:281::GDebugLog: Failed to write the error code

    3936:1604:10/9/2010:18:10:281::FS: NTFS: FindNextFile: Allocation failed

    Can you pl. verify if your system is running out of resources such as virtual memory?

  9. #9
    Join Date
    Apr 2010
    Posts
    30

    Default

    Since your reply, I restarted the zmanda client, and began monitoring it's virtual memory consumption with vmmap.

    To begin with, the process had 2 gigs of virtual memory that it was free to use.

    After the first backup cycle, the process was consuming 1.1 gigs of virtual memory. Even after the backup job was complete, it was still "holding" that much memory, just sitting there.

    After the second backup cycle, it is using 1.8 gigs of virtual memory. The backup job has finished, and it is still holding all that memory. It says this process has 241 megs of vm left.

    I expect that after the next backup run tonight, it will crash again (since I see the crash occur once every several days).

    Why isn't it releasing the memory after each run?

    Here is a snapshot of the vmmap output after the second night's run:



  10. #10
    Join Date
    Apr 2010
    Posts
    30

    Default

    Just as I predicted, the backup run tonight failed. The Zmanda client did not release the virtual memory it had taken from previous nights runs, and so it slowly ran out once it reached 2 gigs virtual memory.

    Please let me know if you have any suggestions. I am running vmmap on a couple other machines that are crashing to see if the problem is occuring there also.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •