Results 1 to 2 of 2

Thread: Invalid tar argument

  1. #1

    Default Invalid tar argument

    Hi All,

    I'm setting up Amanda 3.1.2 on CentOS 5.4 and I'm unable to run a backup on the client as I get the following error:

    Spawning "/bin/tar /bin/tar --create --verbose --file - --directory /home --one-file-system --atime-preserve=system --listed-incremental /var/lib/amanda/gnutar-lists/myhost_home_0.new --sparse --ignore-failed-read --totals --exclude-from /tmp/amanda/amgtar._home.20100917122358.exclude ." in pipeline
    Fri Sep 17 12:23:58 2010: amgtar: 0: strange(?): /bin/tar: option `--atime-preserve' doesn't allow an argument
    Fri Sep 17 12:23:58 2010: amgtar: 0: strange(?): Try `tar --help' or `tar --usage' for more information.

    My tar version is: tar (GNU tar) 1.15.1
    Looking at the man page it says --atime-preserve is the full switch and that it doesn't take an argument.

    Is it possible to alter the parameters being passed to tar? Is there some other dumptype I should be using instead?

    Regards,
    Mike

  2. #2

    Default Solved

    Hi All,

    I managed to find the answer:

    [url]http://wiki.zmanda.com/man/amgtar.8.html[/url]

    ATIME-PRESERVE
    If "YES" (the default), amgtar use the --atime-preserve=system option of gnutar to not update the atime of all files accessed; if "NO", gnutar will updates the atime for all files accessed. This property works only if you have gnutar 1.15.90 or newer, if not, you must set ATIME_PRESERVE to "NO".

    As CENTOS 5.4 has only tar 1.15.1 this is exactly why it won't work.

    IMHO atime is a pretty expensive overhead for filesystems anyway, perhaps I'll turn it off for those partitions I'm backing up.

    Thanks,
    Mike

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •