Results 1 to 4 of 4

Thread: Problem with /mnt/ folder

  1. #1

    Default Problem with /mnt/ folder

    Hi Community,

    I am a new user of Amanda and set it up to backup my entire Linux System, i.e. "/". Doing this, I encountered a problem. I am backing up to a USB harddrive as virtual tape which is in /mnt/backup/DailySet1/.
    My original system contains of two harddrives, of which one is mounted in /mnt/userdata and holds all directories in /home/ through links. So I have my complete System on one harddrive and the home folder on the other harddrive.

    Now when I'm running the backup, it does everything except backing up the user data in /home/ linked to /mnt/userdata. I guess this might be as the backup itself is in the /mnt/-directory, so it maybe completly excludes the mnt-folder?

  2. #2

    Default

    I have a different DLE for each mounted harddisk. So in a system where hd1 is root, hd2 is /home and hd3 is /swrepo, I have 3 DLEs too - one for /, one for /home and one for /swrepo. In other words - the default is to not backup mountpoints. Maybe there is a way to override it with options, but I have not looked it up.

  3. #3

    Default

    Ok, I just added another entry for /mnt/userdata in the disklist, and that already did the job Thanks!

  4. #4

    Default

    I believe GNU tar will not cross mount points if it is invoked with '--one-file-system' or '-l'. Possibly amanda does this. I can see the rationale: if you restore without the volume mounted, you restore a lot of data in the wrong place and may run out of space.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •