Hi.

I use the amfetchdump tool of Amanda (3.1.1). When I give the parameter "-n" I get the following message:

Code:
amfetchdump -l -n Hourly scrserver Piroska 2010080418
Usage: amfetchdump config [-c|-C|-l] [-p|-n] [-a]
    [-O directory] [-d device] [-o configoption]*
    [--header-file file] [--header-fd fd]
    hostname [diskname [datestamp [hostname [diskname [datestamp ... ]]]]]"));
ERROR: -p is not compatible with -n
I have solved the problem with this little patch:
Code:
--- amfetchdump_orig        2010-06-28 23:46:57.000000000 +0200
+++ amfetchdump 2010-08-04 00:20:20.000000000 +0200
@@ -164,7 +164,7 @@
 usage("-l is not compatible with -c or -C")
     if ($opt_leave and $opt_compress);
 usage("-p is not compatible with -n")
-    if ($opt_leave and $opt_no_reassembly);
+    if ($opt_pipe and $opt_no_reassembly);
 usage("-h, --header-file, and --header-fd are mutually incompatible")
     if (($opt_header and $opt_header_file or $opt_header_fd)
            or ($opt_header_file and $opt_header_fd));
I would be grateful if you could fix this bug the next version of Amanda.

Thank you for your help,
Zoli