Results 1 to 4 of 4

Thread: selfcheck request failed: timeout waiting for ACK

  1. #1

    Default selfcheck request failed: timeout waiting for ACK

    dear All

    we just used amanda as backup server for about 5 months ago, and now we got stranger problem

    if we do checking with amcheck to spesified host it work, but if we do check global config we got error warning

    here my disklist config ;

    ns1.my.host.name //www custom-compress
    ns1.my.host.name /backupmysql custom-compress
    ns1.my.host.name /var/named custom-compress
    abi.my.host.name /abi custom-compress
    zimbra.my.host.name /opt/zimbra zimbra
    retail.my.host.name /opt/retail custom-compress
    db.my.host.name /var/bekup custom-compress
    crm.my.host.name /backupmysql custom-compress
    retailsoft-sby.my.host.name /opt/bekup custom-compress
    ns.my.host.name /home/www custom-compress
    ns.my.host.name /var/named custom-compress
    ns.my.host.name /var/lib/mysql custom-compress
    ns.my.host.name /etc custom-compress
    retail-sg.my.host.name /var/backup custom-compress
    retail.other.host.name /opt/POS custom-compress
    retail.other.host.name /var/backup custom-compress

    here the error we got when amcheck global config

    sbin/amcheck myconfig
    Amanda Tape Server Host Check
    -----------------------------
    Holding disk /bekup1: 957325312 KB disk space available, using 956301312 KB
    Holding disk /bekup2: 814583808 KB disk space available, using 813559808 KB
    slot 30: volume 'myconfig-030'
    Will write to volume 'myconfig-030' in slot 30.
    NOTE: skipping tape-writable test
    Server check took 0.551 seconds

    Amanda Backup Client Hosts Check
    --------------------------------
    WARNING: zimbra.my.host.name: selfcheck request failed: timeout waiting for ACK
    WARNING: ns1.my.host.name: selfcheck request failed: timeout waiting for ACK
    WARNING: retail.my.host.name: selfcheck request failed: timeout waiting for ACK
    WARNING: db.my.host.name: selfcheck request failed: timeout waiting for ACK
    WARNING: crm.my.host.name: selfcheck request failed: timeout waiting for ACK
    WARNING: abi.my.host.name: selfcheck request failed: timeout waiting for ACK
    WARNING: retail-sg.my.host.name: selfcheck request failed: timeout waiting for ACK
    Client check: 10 hosts checked in 150.258 seconds. 7 problems found.

    (brought to you by Amanda 3.1.0)

    and with hostname check
    sbin/amcheck myconfig zimbra.my.hosts.name
    Amanda Tape Server Host Check
    -----------------------------
    Holding disk /bekup1: 957325312 KB disk space available, using 956301312 KB
    Holding disk /bekup2: 814583808 KB disk space available, using 813559808 KB
    slot 30: volume 'myconfig-030'
    Will write to volume 'myconfig-030' in slot 30.
    NOTE: skipping tape-writable test
    Server check took 0.551 seconds

    Amanda Backup Client Hosts Check
    --------------------------------
    Client check: 1 host checked in 26.029 seconds. 0 problems found.

    (brought to you by Amanda 3.1.0)

    it's network issued or config issued?

    save our soul


    regards,
    ari

  2. #2
    Join Date
    May 2009
    Posts
    82

    Default

    Ari,

    I don't know what the issue is, but there are several mechanisms that have to be in place to have the systems communicate. One thing you can try is the amservice command (ass root):

    amservice hostname bsdtcp noop </dev/null

    This is going to time out for you. Okay... is your xinetd running. On my Centos box I can stop and start it with:

    service xinetd restart

    Now check the amservice again. What about the /var/lib/amanda/.amandahosts on the client systems. This has to have the proper information about your host to allow access.

    What about DNS.... does DNS work for the server?

    Check that the clients all have their xinetd working properly too. Please let me know what it is.

  3. #3

    Lightbulb

    Hi,

    I had the same problem like you and it was caused because i forget to add in amanda.conf file the following:


    define dumptype global {
    comment "Global definitions"
    auth "bsdtcp"
    # This is quite useful for setting global parameters, so you don't have
    # to type them everywhere. All dumptype definitions in this sample file
    # do include these definitions, either directly or indirectly.
    # There's nothing special about the name `global'; if you create any
    # dumptype that does not contain the word `global' or the name of any
    # other dumptype that contains it, these definitions won't apply.
    # Note that these definitions may be overridden in other
    # dumptypes, if the redefinitions appear *after* the `global'
    # dumptype name.
    # You may want to use this for globally enabling or disabling
    # indexing, recording, etc. Some examples:
    # index yes
    # record no
    # split_diskbuffer "/raid/amanda"
    # fallback_splitsize 64m
    }


    you should put what auth mode you use, i use bsdtcp.

  4. #4

    Default Check dns

    I had the same problem and it was a DNS issue (The NETMASK on both client and Backup server were different)
    you can find more details below
    [URL="http://ycsoftware.net/selfcheck-request-failed-timeout-waiting-for-ack/"]http://ycsoftware.net/selfcheck-request-failed-timeout-waiting-for-ack/[/URL]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •