Results 1 to 7 of 7

Thread: Lenny and MySQL-ZRM 2.2.0 not work with remote backup

  1. #1

    Default Lenny and MySQL-ZRM 2.2.0 not work with remote backup

    Hi all,
    I try local backup with Debian Lenny ad ZRM 2.2, work fine.
    But with ssh or socket copy, ZRM ignore my configuration file and output is:

    ideafactory:backup:INFO: START OF BACKUP
    ideafactory:backup:INFO: PHASE START: Initialization
    ideafactory:backup:INFO: Mail address: [email]info@ideafactory.it[/email] is ok
    ideafactory:backup:INFO: ZRM Temporary configuration file = /etc/mysql-zrm/ideafactory/tmpagHe3.conf
    ideafactory:backup:INFO: {
    ideafactory:backup:INFO: verbose=1
    ideafactory:backup:INFO: retention-policy=15D
    ideafactory:backup:INFO: all-databases=1
    ideafactory:backup:INFO: socket-remote-port=25300
    ideafactory:backup:INFO: password=******
    ideafactory:backup:INFO: backup-mode=raw
    ideafactory:backup:INFO: backup-type=regular
    ideafactory:backup:INFO: compress-plugin=/bin/gzip
    ideafactory:backup:INFO: user=root
    ideafactory:backup:INFO: copy-plugin=/usr/share/mysql-zrm/plugins/socket-copy.pl
    ideafactory:backup:INFO: backup-level=1
    ideafactory:backup:INFO: quiet=0
    ideafactory:backup:INFO: mailto=info@ideafactory.it
    ideafactory:backup:INFO: remote-mysql-binpath=/usr/bin
    ideafactory:backup:INFO: host=wifi.ideafactory.it
    ideafactory:backup:INFO: mail-policy=always
    ideafactory:backup:INFO: comment=ideafactory
    ideafactory:backup:INFO: compress=/bin/gzip
    ideafactory:backup:INFO: }
    ideafactory:backup:INFO: Getting mysql variables
    ideafactory:backup:INFO: mysqladmin --user="root" --password="*****" --host="wifi.ideafactory.it" variables
    ideafactory:backup:ERROR: Output of command: 'mysqladmin --user="root" --password="*****" --host="wifi.ideafactory.it" variables' is {
    mysqladmin: connect to server at 'wifi.ideafactory.it' failed
    error: 'Lost connection to MySQL server at 'reading initial communication packet', system error: 111'
    }
    ideafactory:backup:ERROR: Cannot connect to mysql server!
    ideafactory:backup:INFO: PHASE START: Cleanup
    ideafactory:backup:INFO: mailing file /tmp/Ayl5yK3weL
    ideafactory:backup:INFO: mail command is cat "/tmp/Ayl5yK3weL"|mail -s "[ZRM for MySQL Report] ERROR during backup of backup-set ideafactory" [email]info@ideafactory.it[/email]
    ideafactory:backup:INFO: PHASE END: Cleanup
    ideafactory:backup:INFO: END OF BACKUP
    ERROR: /usr/bin/mysql-zrm did not finish successfully


    My configuration file:
    comment=WiFi
    backup-level=0
    retention-policy=15D
    compress=1
    compress-plugin=/bin/gzip
    all-databases=1
    user="root"
    password="mysecretpass"
    host="wifi.ideafactory.it"
    verbose=1
    mailto="info@ideafactory.it"
    copy-plugin=/usr/share/mysql-zrm/plugins/socket-copy.pl
    remote-mysql-binpath="/usr/bin"
    socket-remote-port="25300"

    Thanks!
    Gianluca

  2. #2

    Default

    Quote Originally Posted by Gemini View Post
    ideafactory:backup:ERROR: Output of command: 'mysqladmin --user="root" --password="*****" --host="wifi.ideafactory.it" variables' is {
    mysqladmin: connect to server at 'wifi.ideafactory.it' failed
    error: 'Lost connection to MySQL server at 'reading initial communication packet', system error: 111'
    }
    id
    There is some problem connecting to the MySQL server remotely. Please see
    [url]http://forums.mysql.com/read.php?52,152265,152265#msg-152265[/url]

  3. #3

    Default

    Sorry but with mysqladmin not use socket copy...
    I want to backup over SSH or socket copy!
    Please help me!
    Thanks!

  4. #4

    Default

    ZRM use mysqladmin "variables" command to determine the values of datadir and other
    MySQL configuration. mysqladmin has to be work from a remote machine even if you
    are planning to using ssh or socket copy plugin.

    Paddy

  5. #5

    Default

    Ok thanks.
    Only one question: it's possibile to change default ssh port 22 to another value?
    Thanks.

  6. #6

    Default

    There is no configuration flag in ZRM to do this, however you can change the default SSH port by modifying /etc/ssh/ssh_config or /etc/sshd/ssh_config and setting the system-wide default port to something else. The ZRM simply executes the ssh command, so it will use whatever port is specified there.

  7. #7
    sfhdweb Guest

    Default

    thanks its very helpful to me

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •