Results 1 to 3 of 3

Thread: how to backup 2.4 client using 2.6 server

  1. #1
    Join Date
    Mar 2010
    Posts
    27

    Default how to backup 2.4 client using 2.6 server

    I have a 2.6.1p2 server that is backing up other 2.6.1p2 clients. Everything is setup with SSH auth.

    I need to bring an older 2.4.4 client into the mix. (It is a RedHat EL3 system with the AMANDA client installed from RedHat Network.) Note that I tried to install the RPM from Zmanda download for a 2.6 client -- but that requires a version of Tar newer than is available. So I thought it might be easier to just stay on the "RedHat path" and try to use the older 2.4 client.

    So I think I need to use BSD authentication with this 2.4 client (ie, inetd/xinetd). But how do I adjust the DLE on the server so the AMANDA server understands?

  2. #2
    Join Date
    Mar 2010
    Posts
    27

    Default

    Answering myself for the benefit of others...

    Note that this is only to setup the 2.4 AMANDA as a backup client. This doesn't enable the AMANDA software on the client to run commands (ie, amrestore!) against the server.

    AMANDA client
    I had already installed the 'amanda-client' package via RHN. (Specifically "amanda-client-2.4.4p1-0.3E.1") The package created an "amanda" user, /var/lib/amanda, etc. Just need to fill in the "/var/lib/amanda/.amandahosts" file. Note that the AMANDA user on this client is "amanda" (v2.4.4 of AMANDA), while the user being permitted from the server is "amandabackup" (v2.6.1 of AMANDA).
    Code:
    localhost amanda
    localhost.localdomain amanda
    amandaserverhostname.example.com  amandabackup   amdump
    Configure xinetd
    Adjust the amanda service def and then reload xinetd (and check with netstat to make sure xinetd is listening on udp/10080.) RPM installed an "/etc/xinetd.d/amanda" service definition, just need to change the "disable = " to Yes.
    Code:
    # default: off
    # description:  The client for the Amanda backup system.\
    #               This must be on for systems being backed up\
    #               by Amanda.
    service amanda
    {
            socket_type             = dgram
            protocol                = udp
            wait                    = yes
            user                    = amanda
            group                   = disk
            server                  = /usr/lib/amanda/amandad 
            disable                 = no
    }
    You will need to configure an INPUT chain firewall rule to allow packets to UDP/10080, tune to your network. If no firewall, then add an "only_fron = network/bits" specification to your xinetd config above.

    AMANDA server
    You may need an OUTPUT firewall rule to allow UDP/10080.

    Finally, add the "auth" type for this client in the disklist entry.
    Code:
    amandaclienthostname.example.com / {
      auth "bsd"
      # and other, unrelated, stuff in here I'm not bothering to show...
    }
    Last edited by craig; March 19th, 2010 at 11:22 AM.

  3. #3
    Join Date
    Mar 2010
    Posts
    27

    Default

    ...but there's more.

    'amcheck myCfg -cl clienthostname.example.com' is happy, but backups don't actually function.

    aside...
    Since this is a 2.4 client I'm stuck with auth "bsd" (if it was 2.5 we could use "bsdtcp".) Turns out you need either kernel modules that do AMANDA connection tracking to open high number TCP ports from the server-to-client, or you have to compile-configure port ranges so you can drill less-wide firewall rules.

    Anyway, needed to allow high-source/high-destination tcp connections from the server-to-the-client for backups to actually work.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •