Results 1 to 9 of 9

Thread: MySQL backup with non-english characters broken

  1. #1

    Default MySQL backup with non-english characters broken

    Hi,

    today, I have checked my mysql backups backed up with ZCB. I find, that the backups with non-english characters are saved in unknown encoding, so I cant read them correctly.

    My database is in UTF-8 encoding and I need to backup tables with czech characters.

    It is not good to realize, that I have been backing up useless data for over two months!

    How long does it take, to fix this issue?

    Thanks.

  2. #2
    Join Date
    Oct 2005
    Posts
    1,559

    Default

    Please use --default-character-set=utf8 in the Extra Parameters field in the Backup What tab in ZCB UI.

    thanks
    Paddy

  3. #3

    Default

    Not working. I try to unpack the .data file from zmanda backup, but my text editor say that backup.sql file is in CP895 encoding (czech characters are corrupted). I have also tried Notepad++ with same results.

    I have attached a screenshot of my backup set settings.

  4. #4

    Default

    The attachement...
    Attached Files Attached Files

  5. #5
    Join Date
    Oct 2005
    Posts
    1,559

    Default

    Can you please add --set-charset=utf8 to the same field?

    These parameters ensures that the MySQL data is in correct character set. The backup.sql file can be in different character set.

    Can you try restoring the data to see if czech characters are preserved?
    What character set do you use for MySQL operations? Please see [url]http://dev.mysql.com/doc/refman/5.0/en/charset-syntax.html[/url] for details.

    Paddy

  6. #6

    Default

    I have added the extra parametr but with no success.

    Restoring data with Zmanda ends with the same result. Czech characters are corrupted.

    I use MySQL 5.1.41, most of my tables have utf8_general_ci collation. To browse the database I use phpMyAdmin or MySQL Workbench.

    I really think that the problem is not in the database, but with the backup file, which is in some strange encoding that does not support czech characters.

    I also have default-character-set=utf8 setting in my my.ini conf file.
    Last edited by kutny; March 18th, 2010 at 07:14 AM.

  7. #7
    Join Date
    Oct 2005
    Posts
    1,559

    Default

    Can you try mysqldump --default-character-set=utf8? Does it work?

    Paddy

  8. #8

    Default

    When I use mysqldump (in standard MySQL directory):

    mysqldump --user=root --password=mypass --databases smm_test > smm_test.sql

    or

    mysqldump --user=root --password=mypass --default-
    character-set=utf8 --databases smm_test > smm_test.sql

    output file is fine (UTF-8 encoding).

    So I tried to set MySQL utilities path in Zmanda to standard MySQL directory (not C:\Program Files\Zmanda\Zmanda Cloud Backup\MySQL\bin) but also with no success. The file is still corrupted.

    I have created a testing database and made a backup of it. The backup file is attached. I hope it helps you solve the problem.
    Attached Files Attached Files

  9. #9
    Join Date
    Oct 2005
    Posts
    1,559

    Default

    It appears the sql backup does not have character encoding correct.

    INSERT INTO `encoding_test` VALUES (1,'????????????'),(2,'??????????');

    Can you please open a support case at Zmanda Network (network.zmanda.com)?

    thanks,
    Paddy

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •